

<!DOCTYPE html>
<html xmlns:og="http://ogp.me/ns#" lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
	
<title>FRESH LITTER: The Chooches of Killington Vermont | YoBeat</title>

<link rel="alternate" type="application/rss+xml" title="YoBeat RSS Feed" href="http://yobeat.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="YoBeat Atom Feed" href="http://yobeat.com/feed/atom/" />
<link rel="pingback" href="http://yobeat.com/xmlrpc.php" />
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>

<!--[if lte IE 7]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie7style.css" media="all" />
<![endif]-->
 <!--[if IE 8]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie8style.css" media="all" />
<script type="text/javascript" src="http://yobeat.com/wp-content/themes/yobeat/js/respond.min.js"></script>
<![endif]-->
 <!--[if IE 9]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie9style.css" media="all" />
<![endif]-->

<!-- <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>
<script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.9.1/jquery-ui.min.js"></script> -->


<!-- This site is optimized with the Yoast SEO plugin v5.7.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="FRESH LITTER: The Chooches of Killington Vermont | YoBeat" />
<meta property="og:description" content="An interview with Chooches leader Joey Leon, plus the full movie Rebirth, filmed in and around Killington, Vermont" />
<meta property="og:url" content="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/" />
<meta property="og:site_name" content="YoBeat" />
<meta property="article:publisher" content="https://www.facebook.com/yobeatdotcom/" />
<meta property="article:tag" content="chooches" />
<meta property="article:tag" content="Joey Leon" />
<meta property="article:tag" content="killington" />
<meta property="article:section" content="Fresh Litter" />
<meta property="article:published_time" content="2017-12-01T06:16:16-08:00" />
<meta property="og:image" content="http://yobeat.com/wp-content/uploads/2017/12/choochesfreshlitter-1.png" />
<meta property="og:image:width" content="1357" />
<meta property="og:image:height" content="860" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="An interview with Chooches leader Joey Leon, plus the full movie Rebirth, filmed in and around Killington, Vermont" />
<meta name="twitter:title" content="FRESH LITTER: The Chooches of Killington Vermont | YoBeat" />
<meta name="twitter:site" content="@yobeat" />
<meta name="twitter:image" content="http://yobeat.com/wp-content/uploads/2017/12/choochesfreshlitter-1.png" />
<meta name="twitter:creator" content="@yobeat" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/yobeat.com\/","name":"YoBeat - Snowboarding Online","potentialAction":{"@type":"SearchAction","target":"http:\/\/yobeat.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/yobeat.com\/2017\/12\/01\/fresh-litter-chooches-killington-vermont\/","sameAs":["https:\/\/www.facebook.com\/yobeatdotcom\/","https:\/\/www.instagram.com\/yobeat\/","http:\/\/youtube.com\/yobeatdotcom","https:\/\/twitter.com\/yobeat"],"@id":"#organization","name":"YoBeat","logo":"http:\/\/yobeat.com\/wp-content\/uploads\/2017\/11\/yobeatcirlcelogo.png"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//css.rating-widget.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="YoBeat &raquo; Feed" href="http://yobeat.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="YoBeat &raquo; Comments Feed" href="http://yobeat.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="YoBeat &raquo; FRESH LITTER: The Chooches of Killington Vermont Comments Feed" href="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/yobeat.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
			
<style type="text/css">
	h1, h2, h3, h4, h5, h6, #top_title_box, .widget_title, .widget_title_two, #home_carousel .jcarousel-skin-tango .carousel_post h1 a, .home_posts_title h2 { font-family:Oswald; }
	.featured_area_content_text, #home_content, #container, .post_one_column h1, .post_mini_one_column h1, .post_two_column h1, .post_three_column h1, .video_widget { font-family:Oswald; }	
    
	h1, h2, h3, h4, h5, h6 { color: #!important; }
	.site_title h1 { color: #!important; } 
	.site_title h1:hover { color: #!important; } 
	a { color: #!important; }
	a:hover, .post_one_column h1 a:hover, .post_two_column h1 a:hover, .post_three_column h1 a:hover, .jcarousel-skin-tango .post_three_column h1 a:hover, .post_mini_one_column h1 a:hover, .post h1 a:hover, .post_category a:hover, .post_comments a:hover { color: #!important; }

	.right-heading h3 { color: #!important; } 

	.footer-heading h3 { color: #!important; } 
	.right-widget li a{ color: #!important; }
	.right-widget li a:hover { color: #!important; }
	.footer-widget li a { color: #!important; }
	.footer-widget li a:hover { color: #!important; }
	#crumbs, #crumbs a{ color: #!important; }
	#crumbs a:hover { color: #!important; }
	
	
	#header, #dc_jqaccordion_widget-7-item ul ul li a { background-color: #!important; } 
	
	#mainMenu ul li a { color: #!important; } 
	#mainMenu ul li a:hover, #mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { color: #!important; } 
	#mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { background: #!important; } 
    #mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { color: #!important; } 	
	#mainMenu.ddsmoothmenu ul li ul li a { color: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a:hover { color: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a, #mainMenu.ddsmoothmenu ul li ul li.current-menu-ancestor > a, #mainMenu.ddsmoothmenu ul li ul li.current-menu-item > a { background: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a:hover { background: #!important; } 
	#secondaryMenu ul a, #signin_box a.signin, #login_box a.login, #login_box a, #signin_menu, #login_menu, #lost_pas a { color: #!important; } 
	
	.post_format { background-color: #!important; } 
	.post_format_video { background-color: #!important; } 
	.post_format_image { background-color: #!important; } 
	
	
	.footer-heading h3 { background: #!important; } 

	#footer_box, .footer-heading h3 { background: #!important; }
	#footer_bottom { background: #!important; }
	
	.single_title h1 { font-size: 36px!important; } 
    
	#sidemenu li a.open, #sidemenu li a:hover, #sidemenu li:first-child a.open { background-color: #f14d4d!important; }
	#header, .archive_title h3, .post, #similar-post .similar_posts, .archive_title_bot h3, .right-heading { border-color: #f14d4d!important; }
	.first_word { color: #f14d4d!important; } 

	
	
	
</style>

<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='colorbox-theme1-css'  href='http://yobeat.com/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/theme1/colorbox.css?ver=1.3.14' type='text/css' media='screen' />
<link rel='stylesheet' id='dashicons-css'  href='http://yobeat.com/wp-includes/css/dashicons.min.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://yobeat.com/wp-includes/js/thickbox/thickbox.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='bbp-default-css'  href='http://yobeat.com/wp-content/plugins/bbpress/templates/default/css/bbpress.css?ver=2.5.14-6684' type='text/css' media='screen' />
<link rel='stylesheet' id='sb_instagram_styles-css'  href='http://yobeat.com/wp-content/plugins/instagram-feed/css/sb-instagram.min.css?ver=1.5' type='text/css' media='all' />
<link rel='stylesheet' id='sb-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='instalink-lite-css'  href='http://yobeat.com/wp-content/plugins/instalinker/assets/instalink-lite/instalink-lite-1.4.0.min.css?ver=1.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='rw-site-rating-css'  href='http://yobeat.com/wp-content/plugins/rating-widget/resources/css/site-rating.css?ver=2.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-audio-player-css'  href='http://yobeat.com/wp-content/plugins/wp-audio-player/css/audioplayer.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wp-audio-player-theme-css'  href='http://yobeat.com/wp-content/plugins/wp-audio-player/css/plugin.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css'  href='http://yobeat.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.37' type='text/css' media='all' />
<link rel='stylesheet' id='rw_toprated-css'  href='http://css.rating-widget.com/wordpress/toprated.css?ck=Y2017M12D01&#038;ver=2.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='rw_recommendations-css'  href='http://css.rating-widget.com/widget/recommendations.css?ck=Y2017M12D01&#038;ver=2.8.9' type='text/css' media='all' />
<link rel='stylesheet' id='prosper-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.4.0/css/font-awesome.min.css?ver=4.4' type='text/css' media='all' />
<link rel='stylesheet' id='prospere_main_style-css'  href='http://yobeat.com/wp-content/plugins/prosperent-suite/includes/css/products.min.css?ver=4.5.8' type='text/css' media='all' />
<link rel='stylesheet' id='slidedeck-css'  href='http://yobeat.com/wp-content/plugins/slidedeck3-personal/css/slidedeck.css?ver=3.2.3' type='text/css' media='screen' />
<link rel='stylesheet' id='my-style-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/yobeat.min.css?ver=1477327217' type='text/css' media='all' />
<link rel='stylesheet' id='shortcodes-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/shortcodes.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='creamsoda_ticker-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/creamsoda_ticker.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/prettyPhoto.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='tipTip-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/tipTip.css?ver=4.8.3' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/responsive.css?ver=4.8.3' type='text/css' media='all' />
<script type="text/javascript">
window.slideDeck2Version = "3.2.3";
window.slideDeck2Distribution = "pro";
</script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/jquery.colorbox-min.js?ver=1.3.14'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/instalinker/assets/instalink-lite/instalink-lite-1.4.0.min.js?ver=1.5.0'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/wp-audio-player/js/audioplayer.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/wp-audio-player/js/plugin.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/stray-quotes/inc/stray_ajax.js?ver=4.8.3'></script>
<link rel='https://api.w.org/' href='http://yobeat.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://yobeat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://yobeat.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='http://yobeat.com/?p=87732' />
<link rel="alternate" type="application/json+oembed" href="http://yobeat.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fyobeat.com%2F2017%2F12%2F01%2Ffresh-litter-chooches-killington-vermont%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://yobeat.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fyobeat.com%2F2017%2F12%2F01%2Ffresh-litter-chooches-killington-vermont%2F&#038;format=xml" />

<!-- This site is using AdRotate v4.6.3 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	.g-2 { margin:1px; }
	.g-3 { margin:1px; }
	.g-4 { margin:1px; }
	.g-5 { margin:1px; }
	.g-6 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript" src="http://yobeat.com/wp-content/plugins/flash-video-player/swfobject.js"></script>
<!-- begin nextgen-smooth scripts -->
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/mootools.v1.11.js"></script>
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/jd.gallery.js"></script>
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/jd.gallery.transitions.js"></script>          
          <link   type="text/css"        href="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/css/jd.gallery.css" rel="stylesheet" media="screen" />
        <!-- end nextgen-smooth scripts -->
       <!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><!-- <meta name="NextGEN" version="2.2.14" /> -->
<link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico">
<link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/fbrfg/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/fbrfg/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/fbrfg/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/fbrfg/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/uploads/fbrfg/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/uploads/fbrfg/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/uploads/fbrfg/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/uploads/fbrfg/apple-touch-icon-152x152.png">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-196x196.png" sizes="196x196">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-160x160.png" sizes="160x160">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-32x32.png" sizes="32x32">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-TileImage" content="/wp-content/uploads/fbrfg/mstile-144x144.png">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml"><link rel="shortcut icon" type="image/x-icon" href="/wp-content/uploads/2014/06/favicon1.jpg" />		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<!-- jQuery Lightbox For Native Galleries v3.2.2 | http://www.viper007bond.com/wordpress-plugins/jquery-lightbox-for-native-galleries/ -->
<script type="text/javascript">
// <![CDATA[
	jQuery(document).ready(function($){
		$(".gallery").each(function(index, obj){
			var galleryid = Math.floor(Math.random()*10000);
			$(obj).find("a").colorbox({rel:galleryid, maxWidth:"95%", maxHeight:"95%"});
		});
		$("a.lightbox").colorbox({maxWidth:"95%", maxHeight:"95%"});
	});
// ]]>
</script>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/plugins/newspage/newspage.css" />
<link rel="icon" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-270x270.jpg" />

<script>
  (function(d) {
    if (d.getElementById('epictv-js-partner-embed')) return;
    var s = d.createElement('script'),
        f = d.getElementsByTagName('script')[0];
    s.id = 'epictv-js-partner-embed';
    s.src = "//www.epictv.com/partner/embed.js";
    f.parentNode.insertBefore(s, f);
  }(document));
</script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
    googletag.defineSlot('/1804608/970x90_Leaderboard', [970, 90], 'div-gpt-ad-1398272425783-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream', [728, 90], 'div-gpt-ad-1398272824134-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream2', [728, 90], 'div-gpt-ad-1403557052229-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream3', [728, 90], 'div-gpt-ad-1403557093235-0').addService(googletag.pubads());
googletag.defineSlot('/1804608/300x600_UpperSidebar', [300, 600], 'div-gpt-ad-1440105287696-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
    googletag.defineSlot('/1804608/300x500_EpicTV', [300, 500], 'div-gpt-ad-1398273088182-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/340x450_Homepage', [340, 450], 'div-gpt-ad-1398272940366-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/MiddleSidebar_300x250', [300, 250], 'div-gpt-ad-1432930178175-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/ThePeoplesCourt_980x100', [980, 100], 'div-gpt-ad-1412715231407-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/Giro_InsultToInjury_980x100', [980, 100], 'div-gpt-ad-1416523422865-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/300x600_LowerSidebar', [300, 600], 'div-gpt-ad-1430774177852-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/Carbon300x600delivery', [300, 600], 'div-gpt-ad-1434652516935-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/300x250_Jared', [300, 250], 'div-gpt-ad-1434661344746-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
   googletag.defineSlot('/1804608/300x600-Jared-Lower', [300, 600], 'div-gpt-ad-1463688777883-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
});
</script>


</head>


<style type="text/css" media="screen">
.comment .comment-text {
    overflow: hidden;
    word-break: break-word;
}
</style>

<body class="post-template-default single single-post postid-87732 single-format-standard Interviews fresh-litter full-movies interviews videos desktop">
    
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5195145-2', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=260670450618668";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>


<div id="all_content">




<div id="header_top_menu">
	
<script type="text/javascript">
(function($){ 
	$(window).load(function(){ 
	   
		$('.demo').csTicker({
		tickerMode: 'mini', 
		tickerTitle: 'Latest >>', 
		autoAnimate: true,
		speed: 600 
		});

	})
})(jQuery);
</script>
	
	<div class="demo">
	<ul>
	
						
		
    	
	
	<li data-link="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/" data-title="FRESH LITTER: The Chooches of Killington Vermont" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/" data-title="TOO HARD&#8217;S YAS QUAIN: The Full Movie" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/29/peoples-court-the-inaugural-201718-competition/" data-title="Return of the People&#8217;s Court &#8211; The Inaugural 2017/18 Competition" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/29/youth-america-furious/" data-title="THE YOUTH OF AMERICA IS FURIOUS" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/27/movie-madness-se-on-mita-on/" data-title="Monday Movie Madness: SE ON MITA ON" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/26/yobeta-soft-impact-travel-guide-chile-japan-sweden-norway-bulgaria/" data-title="YOBETA: Some Soft Impact Travel Tips For Sweden, Norway, Chile, Japan and Bulgaria!" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/24/an-improptu-mission-to-murmansk-with-dwd-and-fix/" data-title="Rats in Russia &#8211; An Impromptu Mission to Murmansk" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/22/open-letter-snow-world-tailgate-alaska/" data-title="AN OPEN LETTER TO THE SNOW WORLD FROM TAILGATE ALASKA" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/22/hump-day-meets-its-saviour-in-pj-gustafsson-the-hero-who-couldnt-care-less/" data-title="Hump Day Meets its Saviour Pj Gustafsson &#8211; The Hero Who Couldn’t Care Less" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/11/21/killingtons-loaded-turkey-rail-jam-2017-results-recap/" data-title="Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?" data-featured="true"></li>

	 
          
           
	</ul>
	</div>
	
        <div id="soc_book">
    	<a href="http://www.twitter.com/yobeat"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/twitter_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/twitter.png" alt="Twitter " title="Twitter " /></a>
	
        <a href="http://www.facebook.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/facebook_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/facebook.png" alt="Facebook " title="Facebook " /></a>
    
    
	    <a href="http://www.vimeo.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/vimeo_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/vimeo.png" alt="Vimeo " title="Vimeo " /></a>
    	
		
        <a href="http://www.youtube.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/youtube_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/youtube.png" alt="Youtube " title="Youtube " /></a>
    	
	    
        <a href="http://www.instagram.com/yobeat"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/instagram_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/instagram.png" alt="Instagram " title="Instagram " /></a>
    
    
    </div>  
    	
</div>



	
	

<div id="header">
<div class="inner">

	<div id="title_box">
		
			
		
	    <a href="http://yobeat.com">
		    		    <img src="http://yobeat.com/wp-content/uploads/2017/09/YobeatLogo_new.png" alt="Logo" id="logo"/>
	    </a>
	  
	 	
    </div>

	<div id="banner_header_970" class="mobile-hidden">
        <!-- 970x90 Leaderboard -->
        <div id='div-gpt-ad-1398272425783-0' style='width:970px; height:90px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1398272425783-0'); });
        </script>
        </div>
	</div>		
	
	<div id="menu_box" class="closed">
		
	
    <div id="mainMenu" class="ddsmoothmenu"><ul id="menu-header" class="menu"><li id="menu-item-57927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57927"><a href="/">Home</a></li>
<li id="menu-item-87666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-87666"><a href="https://yobeat-gear.myshopify.com/">YO Merch</a></li>
<li id="menu-item-57928" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-has-children menu-item-57928"><a href="http://yobeat.com/category/features/">Read</a>
<ul  class="sub-menu">
	<li id="menu-item-57958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57958"><a href="http://yobeat.com/category/features/people-who-are-potentially-more-interesting-than-you/">Hump Day Interviews</a></li>
	<li id="menu-item-87609" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87609"><a href="http://yobeat.com/category/features/quickie-interviews/">Quickies</a></li>
	<li id="menu-item-87610" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87610"><a href="http://yobeat.com/category/features/states-of-shred/">States of Shred</a></li>
	<li id="menu-item-66469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66469"><a href="http://yobeat.com/category/features/summer-shred-guide/">Summer Shred Guide</a></li>
	<li id="menu-item-87611" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87611"><a title="Press Releases" href="http://yobeat.com/category/cause-we-care-about-current-events/">News</a></li>
	<li id="menu-item-87614" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87614"><a title="Satire" href="http://yobeat.com/category/satire/">LULZ</a></li>
</ul>
</li>
<li id="menu-item-57934" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-57934"><a href="http://yobeat.com/category/videos/">Watch</a>
<ul  class="sub-menu">
	<li id="menu-item-87607" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-87607"><a href="http://yobeat.com/category/features/interviews/fresh-litter/">Fresh Litter</a></li>
	<li id="menu-item-87608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87608"><a href="http://yobeat.com/category/features/love-hate/">Love/Hate</a></li>
	<li id="menu-item-87615" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-87615"><a href="http://yobeat.com/category/videos/full-movies/">Full Movies</a></li>
	<li id="menu-item-87616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-87616"><a href="http://yobeat.com/category/videos/teasers/">Teasers</a></li>
</ul>
</li>
<li id="menu-item-58413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58413"><a title="Products you can buy" href="http://yobeat.com/category/features/we-know-everything/">Consume</a></li>
<li id="menu-item-76956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76956"><a href="http://yobeat.com/yo-archives/">Yo-Archives</a></li>
<li id="menu-item-79419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79419"><a href="http://yobeat.com/category/winstuff/">Free Stuff</a></li>
<li id="menu-item-57931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57931"><a href="http://yobeat.com/about/">Support</a></li>
</ul></div>    </div>
	
	
</div>	
</div>

<div class="clear"></div>

<script type="text/javascript" src="http://www.avantlink.com/affiliate_app_confirm.php?mode=js&authResponse=50ceed75f99c06037353a75765848d817f7a5b76"></script>
<div id="main_content"> 
<div class="inner cf">
	
	    
        
        <!-- VIDEO -->
    
        <div class="video-container">
        <iframe src="//www.youtube.com/embed/BvXcVhS4Z0U" frameborder="0" width="100%" webkitallowfullscreen mozallowfullscreen allowfullscreen></iframe>
    </div>
    
    
    <div class="clear"></div>

        
    
            

<div id="single_content">	


<div class="clear"></div>

	
    <div class="single_post" id="post-87732" class="post-87732 post type-post status-publish format-standard has-post-thumbnail hentry category-fresh-litter category-full-movies category-interviews category-videos tag-chooches tag-joey-leon tag-killington fresh-litter full-movies interviews videos">
	
	   	

	   
	    		
	    <div class="single_thumbnail" style="display:none;">
		<a href="http://yobeat.com/wp-content/uploads/2017/12/choochesfreshlitter-1.png" title="FRESH LITTER: The Chooches of Killington Vermont" rel="prettyphoto">
	            <img src="http://yobeat.com/wp-content/uploads/2017/12/choochesfreshlitter-1-760x482.png" alt="FRESH LITTER: The Chooches of Killington Vermont" title="FRESH LITTER: The Chooches of Killington Vermont"/>
	    </a>
		</div>
	    	   
	    			
		
	
	<div class="single_title">	  
	   <h1>FRESH LITTER: The Chooches of Killington Vermont</h1> 
    </div>
	
	<div class="clear"></div>

		
	<div class="post_meta_line">
		<span class="post_time">01 December, 2017</span> 
		<span class="post_cats"><a href="http://yobeat.com/category/features/interviews/fresh-litter/" rel="tag">Fresh Litter</a>, <a href="http://yobeat.com/category/videos/full-movies/" rel="tag">Full Movies</a>, <a href="http://yobeat.com/category/features/interviews/" rel="tag">Interviews</a>, <a href="http://yobeat.com/category/videos/" rel="tag">Videos</a></span> 
		<span class="post_views"><span class="latest-comments">No Comments</span></span>
	</div> 
		
    <div class="clear"></div>
	
    <div class="single_text">
	    <p><em>Rebirth: (noun) a new or second birth, a renewed existence.</em></p>
<blockquote><p><strong>Featuring:</strong> Jake Fournier, Tim Major, Thomas Westcott, Will Steller, Trevor Eichelberger and Joey Leon.</p>
<p><strong>Friends:</strong> Nate Haust, Max Lyons, Austin Esposito, Alfonso Esposito, Savannah Shinske, Jeremy Ellenberg, Levi Gunzburg, George McKeever-Parks, Spencer Davis, Omar Haidara</p></blockquote>
<p><em>Words: Mike Garceau</em></p>
<p><strong><em>Rebirth</em></strong> is a title more significant than the local <a href="http://www.killington.com/site/tickets/tickets_and_cards/lift_tickets">Killington, VT</a> crew, affectionately known as <strong>Chooches</strong>, may have realized when dropping its first full movie. To the Chooches, it meant winter of 2015/16 was basically trash on the East Coast, and for 2016/17 winter had a “rebirth.” So, they got to work filming around the <a href="http://www.killington.com/site/tickets/tickets_and_cards/lift_tickets"><strong>Killington</strong></a> area and throughout <strong>Vermont</strong>.</p>
<p><a href="http://www.killington.com/site/tickets/tickets_and_cards/lift_tickets"><strong>Killington, VT</strong></a> is steeped in snowboard history. It&#8217;s been breeding ground for industry moguls such as <a href="http://www.thepowellmovement.com/tpm-season-1/2017/1/22/tpm-02-pat-bridges-creative-director-snowboarder-magazine"><strong>Bridges</strong></a>, <a href="http://yobeat.com/2000/04/18/snowboard-marketing-gone-bad/"><strong>Land</strong></a>, <a href="https://asymbol.co/collections/tim-zimmerman"><strong>Zimmerman</strong></a>, <a href="http://yobeat.com/2017/09/13/the-brooke-geery-story-a-hump-day-non-exclusive/"><strong>Geery</strong></a> and beyond. It&#8217;s the home base for <a href="http://yobeat.com/2017/02/13/the-not-snowboarding-podcast-ep-54-gbp-gremlinz/"><strong>The Gremlinz/GBP</strong></a>,&nbsp;has hosted major televised events such as the Dew Tour, and these days, is a destination for cash-hungry pro/ams looking to claim <a href="http://yobeat.com/2014/12/07/rails-2-riches-2014-recap/"><strong>Rails 2 Riches</strong></a>.</p>
<p>In recent years though, a lull has existed. A gap in time without a recognized crew of riders, snowboarding their faces off and capturing it on camera. But that lull is over! With Chooches&#8217; &#8220;Rebirth,&#8221; we get adolescent joy in an unpolished, feel-good flick about a group of friends making it happen. We caught up with&nbsp;<strong>Mr. Joey Leon</strong>,&nbsp;post-lecture at Groovy Uvy (UVM) where he&#8217;s currently a freshman to<strong> find out more!&nbsp;</strong></p>
<p><strong>So we know the crew and why the movie is Rebirth… let’s look back at your arrival in <a href="https://www.facebook.com/KillingtonParks/">Killington, VT.</a></strong></p>
<p>Well, I was actually born here, and then moved to Simsbury, CT at two years old. In 2011, my family started to spend weekends and holidays back in VT at our family home. I was part of the weekend program at KMS with my sister (Maggie Leon) and that’s basically where it all began. I was being coached by Evan Ricker at the time, who introduced me to <a href="https://www.darksidesnowboards.com/">Darkside Snowboards</a>, and from there I met <strong>Will Steller</strong>, <strong>Jake Fournier</strong>, and <strong>George McKeever-Parks</strong>. That’s really when the crew formed, when we were like 12 or 13, and we picked up friends along the way.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 658px; padding: 0; width: calc(100% - 2px);" data-instgrm-version="7">
<div style="padding: 8px;">
<div style="background: #F8F8F8; line-height: 0; margin-top: 40px; padding: 50% 0; text-align: center; width: 100%;">&nbsp;</div>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/BbIqab9HoYy/" target="_blank" rel="noopener">A post shared by Joey Leon (@_choooch_)</a> on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2017-11-06T01:28:25+00:00">Nov 5, 2017 at 5:28pm PST</time></p>
</div>
</blockquote>
<p><script async="" defer="" src="//platform.instagram.com/en_US/embeds.js"></script></p>
<p><strong>2011, your family starts spending time in <a href="https://www.facebook.com/KillingtonParks/">Killington, VT</a> again. You’re all of a sudden the young bloods at <a href="https://www.darksidesnowboards.com/">Darkside Snowboards</a>, talk about that impact on you and the crew.</strong></p>
<p><a href="https://www.darksidesnowboards.com/">Darkside</a> has seriously been the biggest influence on my snowboarding, and everything that our crew has accomplished. The support is difficult to put into words. We’d spend hours there, binge watching snowboard movies, hanging with <strong>Ricker</strong> and <strong>Mills</strong>. If we weren’t out riding, we were at <a href="https://www.darksidesnowboards.com/">Darkside</a>, probably being annoying little kids, but we just loved being there. That place is home. Even in the summers, my parents would go golfing, Maggie and I would just spend the day at <a href="https://www.facebook.com/DarksideSnowboards/">Darkside</a>, skating the miniramp. It’s crazy to think how it might be different if we hadn’t had the support of <a href="https://www.facebook.com/DarksideSnowboards/">Darkside</a> from the very beginning.<br />
<a href="https://www.darksidesnowboards.com/">Darkside Snowboards</a> has really been the ticket in <a href="https://www.facebook.com/KillingtonParks/"><strong>Killington, VT</strong></a> and really across the state, supporting so many riders and the local community. What was it like coming into the shop that young, with guys like <strong>Tim Major</strong>, <strong>Ricker</strong>, <strong>Mills</strong>, and I’m sure many more having such a strong presence.</p>
<p>Yeah I mean, <a href="https://www.facebook.com/KillingtonParks/">Darkside</a> for life. It’s so sick that they support us all like they do. Ricker and Mills were a big influence on the direction my snowboarding went. Ricker was literally my coach at KMS for a few years, and Mills always had the camera out. I looked up to Timmy, I still do. He works harder than I think a lot of people realize, like insanely hard when we’re out at spots. In the beginning Timmy always supported my riding, helped out when I couldn’t get a trick, shit like that. I’ve really learned from him, when you’re at a spot the only important thing is to get the shot. Timmy is zero bullshit, it’s just hard work, the second we roll up until everyone has their shot. It’s so sick to have him in our movie now, as a homie that I can always count on, it really brought it all together for me. He’s put out some solo parts, and has had some shots in other movies, and it’s sick for me to give the dude that I look up to a spot in our movie. It really completes it.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 658px; padding: 0; width: calc(100% - 2px);" data-instgrm-version="7">
<div style="padding: 8px;">
<div style="background: #F8F8F8; line-height: 0; margin-top: 40px; padding: 62.5% 0; text-align: center; width: 100%;">&nbsp;</div>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/BZsHOFLnG70/" target="_blank" rel="noopener">A post shared by Joey Leon (@_choooch_)</a> on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2017-10-01T02:50:46+00:00">Sep 30, 2017 at 7:50pm PDT</time></p>
</div>
</blockquote>
<p><script async="" defer="" src="//platform.instagram.com/en_US/embeds.js"></script><br />
<em>Joey, down for life with <a href="https://www.facebook.com/DarksideSnowboards/">Darkside Snowboards</a></em></p>
<p><strong>We’re coming into 2018, why now? It seems like it took a while to get to this point, releasing your first film as, Chooches.</strong></p>
<p>Yo, well there’s more to it. It really goes back to when I met Jake, when we were like 13 or something. We have always been filming, putting shit out on YouTube, really just for us at first. We had no idea what we were doing, and we’re honestly still figuring it out. But anyways, a few seasons back, we filmed an entire movie. It was going to be so sick,<a href="https://www.facebook.com/DarksideSnowboards/"> Darkside</a> Young Bloods, we were so hyped. We’ve moved on and learned a lot, so not going to point any fingers, but we lost the entire movie to a crashed hard drive. It was really, really bad. That experience makes Rebirth mean that much more to us all. We’re stoked to be releasing this, and already we know what we’re looking to change for next year.</p>
<p><strong>Not talking about next year yet&#8230; What’s your favorite clip in the movie?</strong></p>
<p>Timmy’s layback, back 1 out of the wooden close-out. It was so fucked. That was a two-story drop off the back, into a sketchy bank that you can’t even tell in the movie, was all ice. Gnarliest thing I’ve ever filmed, and he just rode away like a G. Oh, and I have to mention Omar! He doesn’t even really snowboard, he’s just part of the crew, and like does his own thing. The ender in the friends segment is Omar, so fucked that he landed that. We were all probably more stoked on that than anyone else putting down a trick in that whole movie.</p>
<p><strong>And there were some decent bails… Any shot that was way harder to get than it should’ve been?</strong></p>
<p>Definitely. We were actually right in Killington, on this wooden rail. Well, most of the movie is wooden rails, but anyways. Yeah, we were working on this rail, sawing down knobs, and yo we actually ran out of there the first day. So creepy, I looked up in this tree and this mannequin head just locked eyes with me, I swear. We literally ran. Went back the next day, the mannequin head wasn’t even there!! But this spot took both Jake and I, a couple hours to get our shots. George is so sick when we&#8217;re at spots and we just can’t get it. Honestly like George is just always down, he’s got a few shots in the friends part, and really he is always there to help make it happen. He’s actually sitting next to me right now, reminding me how hard it was to get that shot, ha.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 658px; padding: 0; width: calc(100% - 2px);" data-instgrm-captioned="" data-instgrm-version="7">
<div style="padding: 8px;">
<div style="background: #F8F8F8; line-height: 0; margin-top: 40px; padding: 28.125% 0; text-align: center; width: 100%;">&nbsp;</div>
<p style="margin: 8px 0 0 0; padding: 0 4px;"><a style="color: #000; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none; word-wrap: break-word;" href="https://www.instagram.com/p/BaXhi4FnwVU/" target="_blank" rel="noopener">its comin up soon!! 💩 @rattletrapgod @darksidevt @mervinmfg @bentmetalbindingworks #mervin_newengland #yogrammies</a></p>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;">A post shared by Joey Leon (@_choooch_) on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2017-10-17T23:28:09+00:00">Oct 17, 2017 at 4:28pm PDT</time></p>
</div>
</blockquote>
<p><script async="" defer="" src="//platform.instagram.com/en_US/embeds.js"></script></p>
<p><strong>The crew seems super close, even though you’re all spread out now at college, right?</strong></p>
<p>Yeah, most of us are away at school. It was hard at first. Will was the first to head out, he’s a bit older than me and he went out to Utah. We’re still super close, and literally we film as much as we can when he is back East on school break. This year more of us are at school though, and I actually think it’s really going to help us. Jake is at URI, George and I are roommates at UVM, and Thomas is up here in Burlington now too. We’ll all meet in <a href="https://www.facebook.com/KillingtonParks/">Killington</a> for the most part, and we can always link with Timmy there. I’m also really stoked to be close to Maggie again, she’s here at UVM too, and we are definitely focused on a full part for her this season. It’s going to be sick to have places to stay, like go hit spots in Rhode Island now, around Burlington and really just get outside of<a href="https://www.facebook.com/KillingtonParks/"> Killington</a> more. The fact that we aren’t around each other as much, I think we’re going to work that much harder at spots and it will all come together, just making us better.</p>
<blockquote class="instagram-media" style="background: #FFF; border: 0; border-radius: 3px; box-shadow: 0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width: 658px; padding: 0; width: calc(100% - 2px);" data-instgrm-version="7">
<div style="padding: 8px;">
<div style="background: #F8F8F8; line-height: 0; margin-top: 40px; padding: 50.0% 0; text-align: center; width: 100%;">&nbsp;</div>
<p style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; line-height: 17px; margin-bottom: 0; margin-top: 8px; overflow: hidden; padding: 8px 0 7px; text-align: center; text-overflow: ellipsis; white-space: nowrap;"><a style="color: #c9c8cd; font-family: Arial,sans-serif; font-size: 14px; font-style: normal; font-weight: normal; line-height: 17px; text-decoration: none;" href="https://www.instagram.com/p/BbndV-yn-26/" target="_blank" rel="noopener">A post shared by Joey Leon (@_choooch_)</a> on <time style="font-family: Arial,sans-serif; font-size: 14px; line-height: 17px;" datetime="2017-11-18T00:32:25+00:00">Nov 17, 2017 at 4:32pm PST</time></p>
</div>
</blockquote>
<p><script async="" defer="" src="//platform.instagram.com/en_US/embeds.js"></script></p>
<p><strong>Now seems like a good time to talk about the plans for this season.</strong></p>
<p>Travel. The more I think about it, the more I realize like 90% of Rebirth is on wooden rails. That’s seriously just because we rarely left <a href="https://www.facebook.com/KillingtonParks/">Killington</a>, and if we did, we were still really close to the area. It’s going to be sick to hit some shit we’re actually comfortable going sideways on, wood is so sketchy. We’re looking at hitting some spots in Canada, and like I said, seeing Jake in Rhode Island and shit. We got a new lens too, been a dream for Jake and I forever, that we never really expected to own. Maggie bought a HVX and her part is really a big focus. Other than that, just going to focus on getting better, filming some more b-roll, new angles… we’re learning a lot and can’t wait to keep going.</p>
<p><strong>Looking forward to seeing it go down man. Any last mentions?</strong></p>
<p>Shout-out to my Mom, have to start there, she is #1. <a href="https://www.facebook.com/DarksideSnowboards/">Darkside Snowboards</a> and the whole family there, <strong>Billy Langlands</strong>, <strong>Evan Ricker</strong>, <strong>Tyler Mills</strong>, <strong>Tucker Zink</strong>, <strong>Ron Chiodi</strong> for all the help on the movie, Killington Parks, and I mean you’re interviewing me, but <strong>Mike Garceau</strong>. There’s really been so many people along the way, and I know I talk for the whole crew when we say we can’t thank everyone enough for all the support. We’re stoked to start filming again, and I hope everyone has a great year.</p>
    </div>
	
	<div class="clear"></div>
    
    <style>
.yobeatsocial {display:block; width:100%; padding: 10px 10px 10px 0px;}
.yobeatsocial .yobeatfblike {float:left; margin-right: 30px;}
.yobeatsocial .yobeattweet {float:left;}
.yobeatsocial .yobeataddthisbutton { float:left;}
</style>
<div class="yobeatsocial">
    <div class="fb-like yobeatfblike" data-href="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
    <a href="https://twitter.com/share" class="twitter-share-button yobeattweet" data-url="http://yobeat.com/2017/12/01/fresh-litter-chooches-killington-vermont/" data-via="yobeat" data-related="yobeat">Tweet</a>
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
    <!-- ADDTHIS BUTTON BEGIN -->
    <script type="text/javascript">
        var addthis_config = {
            services_exclude: 'facebook,twitter'
        }
    </script>
    <a href="http://www.addthis.com/bookmark.php?v=250" 
    class="addthis_counter addthis_pill_style yobeataddthisbutton"></a>
    <script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js"></script>
    <!-- ADDTHIS BUTTON END -->
    <div style="clear:both;"></div>
</div><!--yobeatsocial-->    
    <div class="clear"></div>
    
    <div id="writer" class="cf">
    <p class="cf">
        <img src='http://yobeat.com/wp-content/uploads/thumbnails/admin.jpg' alt='' /> <strong><a href="http://yobeat.com/author/admin/" title="Posts by Nice Kitty" rel="author">Nice Kitty</a></strong> The most Internet-savvy kitty since Keyboard cat.<br />
        <span><a href="/cdn-cgi/l/email-protection#75060017181c06061c1a1b06350c1a171014015b161a18" title='Email this author'>Email this author</a> | All posts by <a href="http://yobeat.com/author/admin/" title="Posts by Nice Kitty" rel="author">Nice Kitty</a></span>
    </p>
    <div class="cf"></div>
</div>
    
    <div class="clear"></div>
	
		
		<ul id="tags_simple"><li><a href="http://yobeat.com/tag/chooches/" rel="tag">chooches</a></li><li><a href="http://yobeat.com/tag/joey-leon/" rel="tag">Joey Leon</a></li><li><a href="http://yobeat.com/tag/killington/" rel="tag">killington</a></li></ul>		
    	
	<div class="clear"></div>
	
	<div id="navigation_images">
    	<div class="alignleft">
    	        <a href="http://yobeat.com/2017/11/30/stinky-socks-holiday-lookbook-2017/">
    	<img width="150" height="150" src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-30-at-3.36.24-PM-150x150.png" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" 0="90" 1="90" />    	</a>
            	
    	<div class="prev_link_title">
    	<span>- Previous article</span> </br>
        &laquo; <a href="http://yobeat.com/2017/11/30/stinky-socks-holiday-lookbook-2017/" rel="prev">Stinky Socks Holiday Look Book 2017</a>        </div>
    	
    	</div> 
    	
    	<div class="alignright">
    	
    	    	
    	<div class="next_link_title">
    	<span>Next article -</span></br>
    	        </div>
    	</div>

	</div> 
	
	<div class="clear"></div>
	
    	<div id="similar-post" class="mosaicflow" data-item-selector=".similar_posts" data-min-item-width="200"> 
 
	    <h3> Similar posts </h3><div class="clear"></div><ul>		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2017/11/21/killingtons-loaded-turkey-rail-jam-2017-results-recap/" title="Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?" >
			            <img src="http://yobeat.com/wp-content/uploads/2017/11/maggiemain-360x220.jpg" alt="Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?" title="Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2017/11/21/killingtons-loaded-turkey-rail-jam-2017-results-recap/" title="Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?" >Killington&#8217;s Loaded Turkey Rail Jam &#8217;17 &#8212; Dinner with the Leons!?</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/event-coverage/" rel="tag">Event Coverage</a>, <a href="http://yobeat.com/category/features/" rel="tag">Features</a></span>
			
	    </li>
		
        		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2017/11/15/last-weekend-whenever-rust-killington-opening-video/" title="Last Weekend, Whenever: Rust &#8211; A Killington Opening Video" >
			            <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-15-at-2.21.10-PM-360x220.png" alt="Last Weekend, Whenever: Rust &#8211; A Killington Opening Video" title="Last Weekend, Whenever: Rust &#8211; A Killington Opening Video"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2017/11/15/last-weekend-whenever-rust-killington-opening-video/" title="Last Weekend, Whenever: Rust &#8211; A Killington Opening Video" >Last Weekend, Whenever: Rust &#8211; A Killington Opening Video</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/features/" rel="tag">Features</a>, <a href="http://yobeat.com/category/videos/" rel="tag">Videos</a></span>
			
	    </li>
		
        		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2017/03/01/darkside-grudge-match-2017/" title="Darkside Grudge Match 2017" >
			            <img src="http://yobeat.com/wp-content/uploads/2017/03/Screen-Shot-2017-03-01-at-1.25.34-PM-360x220.png" alt="Darkside Grudge Match 2017" title="Darkside Grudge Match 2017"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2017/03/01/darkside-grudge-match-2017/" title="Darkside Grudge Match 2017" >Darkside Grudge Match 2017</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/features/" rel="tag">Features</a>, <a href="http://yobeat.com/category/videos/" rel="tag">Videos</a></span>
			
	    </li>
		
        </ul>        		
    </div>	 
		 
	
	<div class="clear"></div>

		
		
	<div id="comments">

<!-- You can start editing here. -->

	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2017/12/01/fresh-litter-chooches-killington-vermont/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://yobeat.com/wp-comments-post.php?wpe-comment-post=yobeat" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='87732' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="4c1cff44b8" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="21"/></p>			</form>
			</div><!-- #respond -->
	
</div>

<div class="clear"></div>	
		
	
			 

</div>

</div>
	
<div class="right-sidebar">
    
<div id="sidebar-right">

<div class="right-sidebar-widget widget_search">
<form class="search" method="get" action="http://yobeat.com/">
	<input type="text" name="s" id="s" placeholder="Search..." />
</form></div><div class="right-sidebar-widget widget_recent_comments"><div class="right-heading"><h3>Recent Comments</h3></div> <div class="clear"></div><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">vegan food for thought</span> on <a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/comment-page-2/#comment-1135771">TOO HARD&#8217;S YAS QUAIN: The Full Movie</a></li><li class="recentcomments"><span class="comment-author-link">vegan food for thought</span> on <a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/comment-page-2/#comment-1135770">TOO HARD&#8217;S YAS QUAIN: The Full Movie</a></li><li class="recentcomments"><span class="comment-author-link">vegan food for thought</span> on <a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/comment-page-2/#comment-1135769">TOO HARD&#8217;S YAS QUAIN: The Full Movie</a></li><li class="recentcomments"><span class="comment-author-link">welp</span> on <a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/comment-page-1/#comment-1135768">TOO HARD&#8217;S YAS QUAIN: The Full Movie</a></li><li class="recentcomments"><span class="comment-author-link">just snowboard without a camera so we don't have to see it</span> on <a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/comment-page-1/#comment-1135767">TOO HARD&#8217;S YAS QUAIN: The Full Movie</a></li></ul></div><div class="right-sidebar-widget custom-recent-category-widget"><div class="right-heading"><h3>News You Can Use</h3></div> <div class="clear"></div>
		<ul class="widget_recent_posts">
						<li>
								<a href="http://yobeat.com/2017/11/26/yobeta-lofotenriksgransen-johan-rosen/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-26-at-7.48.11-AM-90x65.png" alt="YoBETA: Lofoten and Riksgränsen Norway with Johan Rosen" title="YoBETA: Lofoten and Riksgränsen Norway with Johan Rosen" />
				</span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/26/yobeta-lofotenriksgransen-johan-rosen/" rel="bookmark">YoBETA: Lofoten and Riksgränsen Norway with Johan Rosen</a>
				<div class="widget_date">26 November, 2017</div>
			    </div>
			<div class="clear"></div>
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/26/yobeta-bulgaria-kareem-el-rafie/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/17881653_1699034283456490_5844956487012581376_n-90x65.jpg" alt="YoBETA: Bulgaria with Kareem el Rafie" title="YoBETA: Bulgaria with Kareem el Rafie" />
				</span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/26/yobeta-bulgaria-kareem-el-rafie/" rel="bookmark">YoBETA: Bulgaria with Kareem el Rafie</a>
				<div class="widget_date">26 November, 2017</div>
			    </div>
			<div class="clear"></div>
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/26/yobeta-hemavan-sweden-lowe-andersson/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/lowe-selfie-90x65.jpg" alt="YoBETA: Hemavan, SWEDEN with Lowe Andersson" title="YoBETA: Hemavan, SWEDEN with Lowe Andersson" />
				</span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/26/yobeta-hemavan-sweden-lowe-andersson/" rel="bookmark">YoBETA: Hemavan, SWEDEN with Lowe Andersson</a>
				<div class="widget_date">26 November, 2017</div>
			    </div>
			<div class="clear"></div>
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/26/yobeta-japan-nils-arvidsson/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-26-at-6.28.55-AM-90x65.png" alt="YoBETA: Japan with Nils Arvidsson" title="YoBETA: Japan with Nils Arvidsson" />
				</span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/26/yobeta-japan-nils-arvidsson/" rel="bookmark">YoBETA: Japan with Nils Arvidsson</a>
				<div class="widget_date">26 November, 2017</div>
			    </div>
			<div class="clear"></div>
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/26/yobeta-chile-nate-johnstone/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Jerome-Tanon-1Nils-Chile-90x65.jpg" alt="YoBETA: Chile with Nate Johnstone" title="YoBETA: Chile with Nate Johnstone" />
				</span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/26/yobeta-chile-nate-johnstone/" rel="bookmark">YoBETA: Chile with Nate Johnstone</a>
				<div class="widget_date">26 November, 2017</div>
			    </div>
			<div class="clear"></div>
			</li>
						</ul>
			</div><div class="right-sidebar-widget popular-widget"><div class="right-heading"><h3>Popular Posts</h3></div> <div class="clear"></div>
		<ul class="widget_recent_posts">
						<li>
								<a href="http://yobeat.com/2017/11/16/hot-box-bitches-deserve-respect/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/hotboxmain-90x65.jpg" alt="Hot Box: Bitches Deserve Respect!" title="Hot Box: Bitches Deserve Respect!" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/16/hot-box-bitches-deserve-respect/" rel="bookmark">Hot Box: Bitches Deserve Respect!</a>
				<div class="widget_date">16 November, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/22/open-letter-snow-world-tailgate-alaska/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-22-at-3.39.27-PM-90x65.png" alt="AN OPEN LETTER TO THE SNOW WORLD FROM TAILGATE ALASKA" title="AN OPEN LETTER TO THE SNOW WORLD FROM TAILGATE ALASKA" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/22/open-letter-snow-world-tailgate-alaska/" rel="bookmark">AN OPEN LETTER TO THE SNOW WORLD FROM TAILGATE ALASKA</a>
				<div class="widget_date">22 November, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-30-at-5.44.03-AM-90x65.png" alt="TOO HARD'S YAS QUAIN: The Full Movie" title="TOO HARD'S YAS QUAIN: The Full Movie" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/30/hards-yas-quain-full-movie/" rel="bookmark">TOO HARD'S YAS QUAIN: The Full Movie</a>
				<div class="widget_date">30 November, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/02/weekend-plans-slc-shred-fest-2-0-liberty-park/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/BigUintas-90x65.jpg" alt="Weekend Plans: SLC Shred Fest 2.0 at Liberty Park" title="Weekend Plans: SLC Shred Fest 2.0 at Liberty Park" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/02/weekend-plans-slc-shred-fest-2-0-liberty-park/" rel="bookmark">Weekend Plans: SLC Shred Fest 2.0 at Liberty Park</a>
				<div class="widget_date">02 November, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/11/22/hump-day-meets-its-saviour-in-pj-gustafsson-the-hero-who-couldnt-care-less/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/11/Screen-Shot-2017-11-20-at-3.51.06-AM-90x65.png" alt="Hump Day Meets its Saviour Pj Gustafsson - The Hero Who Couldn’t Care Less" title="Hump Day Meets its Saviour Pj Gustafsson - The Hero Who Couldn’t Care Less" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/11/22/hump-day-meets-its-saviour-in-pj-gustafsson-the-hero-who-couldnt-care-less/" rel="bookmark">Hump Day Meets its Saviour Pj Gustafsson - The Hero Who Couldn’t Care Less</a>
				<div class="widget_date">22 November, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
						</ul>
			</div> 	

</div>
  
</div>
	
</div>
</div>

<div class="clear"></div>
	
<div class="clear"></div>

<br />

<div id="footer_bottom"> 

    <div id="secondaryMenu" class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-65403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65403"><a href="http://yobeat.com/about/">About The &#8216;BEAT</a></li>
<li id="menu-item-65404" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65404"><a href="http://yobeat.com/selfserveadvertising/">Advertise</a></li>
</ul></div>

    <div id="credit">     
	 &copy; 2017 	  All rights reserved -
	  <a href="http://yobeat.com" title="YoBeat">YoBeat</a>.
	  &nbsp;  Built By <a href="http://clave.me/" target="blank">Clave Media</a>
    </div>	


</div>

<script data-cfasync="false" src="/cdn-cgi/scripts/ddc5a536/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">
jQuery(document).ready(function($){
	$(".tagcloud a").hover(function() {
    $(this).animate({ backgroundColor: "#f14d4d" }, 200);
    },function() {
    $(this).animate({ backgroundColor: "#444" }, 200);
    });
});
</script>

</div>
<a href="#top" class="scroll-top-link mobile-hidden">TOP</a>
<!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/yobeat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/yobeat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/yobeat.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/yobeat.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/bbpress/templates/default/js/editor.js?ver=2.5.14-6684'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sb_instagram_js_options = {"sb_instagram_at":"8103617.3a81a9f.1cfa6ad1744c4cb4a15a668530643c62"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/instagram-feed/js/sb-instagram.min.js?ver=1.5'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.totemticker.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/carousel.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/creamsoda_ticker.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/carousel_plugins.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.flexslider-min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/ddsmoothmenu.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.easing.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.mosaicflow.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.color.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.prettyPhoto.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.tipTip.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/modernizr.custom.46884.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/css_browser_selector.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/yobeat.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/comment-reply.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jail.js?ver=3.2.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jquery-mousewheel/jquery.mousewheel.min.js?ver=3.0.6'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jquery.easing.1.3.js?ver=1.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/slidedeck.jquery.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/slidedeck-public.js?ver=3.2.3'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1316526300'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/wp-embed.min.js?ver=4.8.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0'></script>
<script type="text/javascript">
var slideDeck2URLPath = "http://yobeat.com/wp-content/plugins/slidedeck3-personal";
var slideDeck2iframeByDefault = false;
</script>


<!-- Start Quantcast tag -->
<script type="text/javascript">_qoptions={qacct:"p-505kElD5BGXpI"};</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript><img src="http://pixel.quantserve.com/pixel/p-505kElD5BGXpI.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript>
<!-- End Quantcast tag -->

<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script>


</body>

</html>
	
	