

<!DOCTYPE html>
<html xmlns:og="http://ogp.me/ns#" lang="en-US">
<head>
<meta charset="UTF-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
	
<title>  High Fives with Todd Richards- Mexican Drugs!</title>
<!-- Facebook Open Graph -->
<meta property="fb:app_id"      content="380062550934" /> 
<meta property="fb:admins" 		content="23510087"/>
<meta property="fb:admins" 		content="672201054"/>
<meta property="og:site_name" 	content="YoBeat"/>

    
    
    
    <meta property="og:url" content="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/" /> 
    <meta property="og:title" content="High Fives with Todd Richards- Mexican Drugs!" /> 
    <meta property="og:description" content="" /> 
    <meta property="og:type" content="article"/>
            <meta property="og:image" content="http://yobeat.com/wp-content/themes/yobeat/includes/tt.php?w=200&h=200&src=http://yobeat.com/wp-content/uploads/2009/08/tr_drugs_home.jpg">
            
<!-- Facebook Open Graph --><link rel="alternate" type="application/rss+xml" title="YoBeat: Softcore Snowboarding Since 1997 RSS Feed" href="http://yobeat.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="YoBeat: Softcore Snowboarding Since 1997 Atom Feed" href="http://yobeat.com/feed/atom/" />
<link rel="pingback" href="http://yobeat.com/xmlrpc.php" />
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>
<link href="http://fonts.googleapis.com/css?family=Oswald" rel="stylesheet" type="text/css" media="all"/>

<!--[if lte IE 7]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie7style.css" media="all" />
<![endif]-->
 <!--[if IE 8]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie8style.css" media="all" />
<script type="text/javascript" src="http://yobeat.com/wp-content/themes/yobeat/js/respond.min.js"></script>
<![endif]-->
 <!--[if IE 9]>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/themes/yobeat/css/ie9style.css" media="all" />
<![endif]-->

<!-- <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.8.2/jquery.min.js"></script>
<script src="http://ajax.googleapis.com/ajax/libs/jqueryui/1.9.1/jquery-ui.min.js"></script> -->

<link rel='dns-prefetch' href='//css.rating-widget.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="YoBeat: Softcore Snowboarding Since 1997 &raquo; Feed" href="http://yobeat.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="YoBeat: Softcore Snowboarding Since 1997 &raquo; Comments Feed" href="http://yobeat.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="YoBeat: Softcore Snowboarding Since 1997 &raquo; High Fives with Todd Richards- Mexican Drugs! Comments Feed" href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/yobeat.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.1"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b===c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
			
<style type="text/css">
	h1, h2, h3, h4, h5, h6, #top_title_box, .widget_title, .widget_title_two, #home_carousel .jcarousel-skin-tango .carousel_post h1 a, .home_posts_title h2 { font-family:Oswald; }
	.featured_area_content_text, #home_content, #container, .post_one_column h1, .post_mini_one_column h1, .post_two_column h1, .post_three_column h1, .video_widget { font-family:Oswald; }	
    
	h1, h2, h3, h4, h5, h6 { color: #!important; }
	.site_title h1 { color: #!important; } 
	.site_title h1:hover { color: #!important; } 
	a { color: #!important; }
	a:hover, .post_one_column h1 a:hover, .post_two_column h1 a:hover, .post_three_column h1 a:hover, .jcarousel-skin-tango .post_three_column h1 a:hover, .post_mini_one_column h1 a:hover, .post h1 a:hover, .post_category a:hover, .post_comments a:hover { color: #!important; }

	.right-heading h3 { color: #!important; } 

	.footer-heading h3 { color: #!important; } 
	.right-widget li a{ color: #!important; }
	.right-widget li a:hover { color: #!important; }
	.footer-widget li a { color: #!important; }
	.footer-widget li a:hover { color: #!important; }
	#crumbs, #crumbs a{ color: #!important; }
	#crumbs a:hover { color: #!important; }
	
	
	#header, #dc_jqaccordion_widget-7-item ul ul li a { background-color: #!important; } 
	
	#mainMenu ul li a { color: #!important; } 
	#mainMenu ul li a:hover, #mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { color: #!important; } 
	#mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { background: #!important; } 
    #mainMenu ul li.current-menu-parent > a, #mainMenu ul li.current_page_item > a, #mainMenu ul li.current-menu-ancestor > a, #mainMenu ul li.current-menu-item > a, #mainMenu ul li a:hover { color: #!important; } 	
	#mainMenu.ddsmoothmenu ul li ul li a { color: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a:hover { color: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a, #mainMenu.ddsmoothmenu ul li ul li.current-menu-ancestor > a, #mainMenu.ddsmoothmenu ul li ul li.current-menu-item > a { background: #!important; } 
	#mainMenu.ddsmoothmenu ul li ul li a:hover { background: #!important; } 
	#secondaryMenu ul a, #signin_box a.signin, #login_box a.login, #login_box a, #signin_menu, #login_menu, #lost_pas a { color: #!important; } 
	
	.post_format { background-color: #!important; } 
	.post_format_video { background-color: #!important; } 
	.post_format_image { background-color: #!important; } 
	
	
	.footer-heading h3 { background: #!important; } 

	#footer_box, .footer-heading h3 { background: #!important; }
	#footer_bottom { background: #!important; }
	
	.single_title h1 { font-size: 36px!important; } 
    
	#sidemenu li a.open, #sidemenu li a:hover, #sidemenu li:first-child a.open { background-color: #f14d4d!important; }
	#header, .archive_title h3, .post, #similar-post .similar_posts, .archive_title_bot h3, .right-heading { border-color: #f14d4d!important; }
	.first_word { color: #f14d4d!important; } 

	
	
	
</style>

<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='colorbox-theme1-css'  href='http://yobeat.com/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/theme1/colorbox.css?ver=1.3.14' type='text/css' media='screen' />
<link rel='stylesheet' id='dashicons-css'  href='http://yobeat.com/wp-includes/css/dashicons.min.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='thickbox-css'  href='http://yobeat.com/wp-includes/js/thickbox/thickbox.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='instalink-lite-css'  href='http://yobeat.com/wp-content/plugins/instalinker/assets/instalink-lite/instalink-lite-1.4.0.min.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='rw-site-rating-css'  href='http://yobeat.com/wp-content/plugins/rating-widget/resources/css/site-rating.css?ver=2.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='sagenda-css'  href='http://yobeat.com/wp-content/plugins/sagenda/css/sagenda.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-audio-player-css'  href='http://yobeat.com/wp-content/plugins/wp-audio-player/css/audioplayer.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wp-audio-player-theme-css'  href='http://yobeat.com/wp-content/plugins/wp-audio-player/css/plugin.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpProQuiz_front_style-css'  href='http://yobeat.com/wp-content/plugins/wp-pro-quiz/css/wpProQuiz_front.min.css?ver=0.36' type='text/css' media='all' />
<link rel='stylesheet' id='rw_toprated-css'  href='http://css.rating-widget.com/wordpress/toprated.css?ck=Y2017M09D05&#038;ver=2.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='rw_recommendations-css'  href='http://css.rating-widget.com/widget/recommendations.css?ck=Y2017M09D05&#038;ver=2.5.9' type='text/css' media='all' />
<link rel='stylesheet' id='slidedeck-css'  href='http://yobeat.com/wp-content/plugins/slidedeck3-personal/css/slidedeck.css?ver=3.2.3' type='text/css' media='screen' />
<link rel='stylesheet' id='my-style-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/yobeat.min.css?ver=1477327217' type='text/css' media='all' />
<link rel='stylesheet' id='shortcodes-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/shortcodes.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='creamsoda_ticker-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/creamsoda_ticker.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='prettyPhoto-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/prettyPhoto.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='tipTip-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/tipTip.css?ver=4.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css'  href='http://yobeat.com/wp-content/themes/yobeat/css/responsive.css?ver=4.8.1' type='text/css' media='all' />
<script type="text/javascript">
window.slideDeck2Version = "3.2.3";
window.slideDeck2Distribution = "pro";
</script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/jquery-lightbox-for-native-galleries/colorbox/jquery.colorbox-min.js?ver=1.3.14'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/instalinker/assets/instalink-lite/instalink-lite-1.4.0.min.js?ver=1.4.0'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/wp-audio-player/js/audioplayer.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/wp-audio-player/js/plugin.min.js?ver=1.9.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/stray-quotes/inc/stray_ajax.js?ver=4.8.1'></script>
<link rel='https://api.w.org/' href='http://yobeat.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://yobeat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://yobeat.com/wp-includes/wlwmanifest.xml" /> 
<link rel="canonical" href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/" />
<link rel='shortlink' href='http://yobeat.com/?p=6557' />
<link rel="alternate" type="application/json+oembed" href="http://yobeat.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fyobeat.com%2F2009%2F08%2F28%2Fhigh-fives-with-todd-richards-15%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://yobeat.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fyobeat.com%2F2009%2F08%2F28%2Fhigh-fives-with-todd-richards-15%2F&#038;format=xml" />

<!-- This site is using AdRotate v3.11.7 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:1px; }
	.g-2 { margin:1px; }
	.g-3 { margin:1px; }
	.g-4 { margin:1px; }
	.g-5 { margin:1px; }
	.g-6 { margin:1px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<script type="text/javascript" src="http://yobeat.com/wp-content/plugins/flash-video-player/swfobject.js"></script>
<!-- <meta name="NextGEN" version="2.1.2" /> -->
<!-- begin nextgen-smooth scripts -->
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/mootools.v1.11.js"></script>
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/jd.gallery.js"></script>
          <script type="text/javascript"  src="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/scripts/jd.gallery.transitions.js"></script>          
          <link   type="text/css"        href="http://yobeat.com/wp-content/plugins/nextgen-smooth-gallery/SmoothGallery/css/jd.gallery.css" rel="stylesheet" media="screen" />
        <!-- end nextgen-smooth scripts -->
               <script type="text/javascript">
            var ajaxurl = 'http://yobeat.com/wp-admin/admin-ajax.php';
        </script>
        <!--[if lt IE 9]><script src="http://html5shim.googlecode.com/svn/trunk/html5.js"></script><![endif]--><link rel="shortcut icon" href="/wp-content/uploads/fbrfg/favicon.ico">
<link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/fbrfg/apple-touch-icon-57x57.png">
<link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/fbrfg/apple-touch-icon-114x114.png">
<link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/fbrfg/apple-touch-icon-72x72.png">
<link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/fbrfg/apple-touch-icon-144x144.png">
<link rel="apple-touch-icon" sizes="60x60" href="/wp-content/uploads/fbrfg/apple-touch-icon-60x60.png">
<link rel="apple-touch-icon" sizes="120x120" href="/wp-content/uploads/fbrfg/apple-touch-icon-120x120.png">
<link rel="apple-touch-icon" sizes="76x76" href="/wp-content/uploads/fbrfg/apple-touch-icon-76x76.png">
<link rel="apple-touch-icon" sizes="152x152" href="/wp-content/uploads/fbrfg/apple-touch-icon-152x152.png">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-196x196.png" sizes="196x196">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-160x160.png" sizes="160x160">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-96x96.png" sizes="96x96">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-16x16.png" sizes="16x16">
<link rel="icon" type="image/png" href="/wp-content/uploads/fbrfg/favicon-32x32.png" sizes="32x32">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="msapplication-TileImage" content="/wp-content/uploads/fbrfg/mstile-144x144.png">
<meta name="msapplication-config" content="/wp-content/uploads/fbrfg/browserconfig.xml"><link rel="shortcut icon" type="image/x-icon" href="/wp-content/uploads/2014/06/favicon1.jpg" /><!-- jQuery Lightbox For Native Galleries v3.2.2 | http://www.viper007bond.com/wordpress-plugins/jquery-lightbox-for-native-galleries/ -->
<script type="text/javascript">
// <![CDATA[
	jQuery(document).ready(function($){
		$(".gallery").each(function(index, obj){
			var galleryid = Math.floor(Math.random()*10000);
			$(obj).find("a").colorbox({rel:galleryid, maxWidth:"95%", maxHeight:"95%"});
		});
		$("a.lightbox").colorbox({maxWidth:"95%", maxHeight:"95%"});
	});
// ]]>
</script>
<link rel="stylesheet" type="text/css" href="http://yobeat.com/wp-content/plugins/newspage/newspage.css" />
<link rel="icon" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-32x32.jpg" sizes="32x32" />
<link rel="icon" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-180x180.jpg" />
<meta name="msapplication-TileImage" content="http://yobeat.com/wp-content/uploads/2015/11/cropped-yobeatsince1997r-270x270.jpg" />

<script>
  (function(d) {
    if (d.getElementById('epictv-js-partner-embed')) return;
    var s = d.createElement('script'),
        f = d.getElementsByTagName('script')[0];
    s.id = 'epictv-js-partner-embed';
    s.src = "//www.epictv.com/partner/embed.js";
    f.parentNode.insertBefore(s, f);
  }(document));
</script>

<script type='text/javascript'>
var googletag = googletag || {};
googletag.cmd = googletag.cmd || [];
(function() {
var gads = document.createElement('script');
gads.async = true;
gads.type = 'text/javascript';
var useSSL = 'https:' == document.location.protocol;
gads.src = (useSSL ? 'https:' : 'http:') + 
'//www.googletagservices.com/tag/js/gpt.js';
var node = document.getElementsByTagName('script')[0];
node.parentNode.insertBefore(gads, node);
})();
</script>

<script type='text/javascript'>
googletag.cmd.push(function() {
    googletag.defineSlot('/1804608/970x90_Leaderboard', [970, 90], 'div-gpt-ad-1398272425783-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream', [728, 90], 'div-gpt-ad-1398272824134-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream2', [728, 90], 'div-gpt-ad-1403557052229-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/728x90_ContentStream3', [728, 90], 'div-gpt-ad-1403557093235-0').addService(googletag.pubads());
googletag.defineSlot('/1804608/300x600_UpperSidebar', [300, 600], 'div-gpt-ad-1440105287696-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
    googletag.defineSlot('/1804608/300x500_EpicTV', [300, 500], 'div-gpt-ad-1398273088182-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/340x450_Homepage', [340, 450], 'div-gpt-ad-1398272940366-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/MiddleSidebar_300x250', [300, 250], 'div-gpt-ad-1432930178175-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/ThePeoplesCourt_980x100', [980, 100], 'div-gpt-ad-1412715231407-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/Giro_InsultToInjury_980x100', [980, 100], 'div-gpt-ad-1416523422865-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/300x600_LowerSidebar', [300, 600], 'div-gpt-ad-1430774177852-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/Carbon300x600delivery', [300, 600], 'div-gpt-ad-1434652516935-0').addService(googletag.pubads());
    googletag.defineSlot('/1804608/300x250_Jared', [300, 250], 'div-gpt-ad-1434661344746-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
   googletag.defineSlot('/1804608/300x600-Jared-Lower', [300, 600], 'div-gpt-ad-1463688777883-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
});
</script>


</head>


<style type="text/css" media="screen">
.comment .comment-text {
    overflow: hidden;
    word-break: break-word;
}
</style>

<body class="post-template-default single single-post postid-6557 single-format-standard features desktop">
    
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-5195145-2', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

<div id="fb-root"></div>
<script>(function(d, s, id) {
    var js, fjs = d.getElementsByTagName(s)[0];
    if (d.getElementById(id)) return;
    js = d.createElement(s); js.id = id;
    js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=260670450618668";
    fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));
</script>

        <style type="text/css">body{padding:210px 0 0 0 !important;}</style>
        <div class="g g-1"><div class="g-single a-42"><div id="bglink"><a class="gofollow" data-track="NDIsMSwxLDYw" href="http://yobeatstore.com"><img src="http://yobeat.com/wp-content/uploads/2017/06/Yobeat-site-skin-store-20172-copy.jpg" /></a></div></div></div>
<div id="all_content">




<div id="header_top_menu">
	
<script type="text/javascript">
(function($){ 
	$(window).load(function(){ 
	   
		$('.demo').csTicker({
		tickerMode: 'mini', 
		tickerTitle: 'Latest >>', 
		autoAnimate: true,
		speed: 600 
		});

	})
})(jQuery);
</script>
	
	<div class="demo">
	<ul>
	
						
		
    	
	
	<li data-link="http://yobeat.com/2017/09/05/under-review-summit-plus-vaporizer-by-vapium/" data-title="Under Review: Summit Plus Vaporizer by Vapium" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/09/04/hood-report-2017-timberline-treated-to-the-the-best-summer-in-years/" data-title="Hood Report 2017: Timberline Treated to the Best Summer in Years" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/09/01/throwback-thursday-urban-first-descents/" data-title="Throwback Thursday: Urban First Descents" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/08/31/whole-lotta-gang-shit/" data-title="WHOLE LOTTA GANG SHIT!" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/08/16/max-lyons-peaked-in-middle-school/" data-title="Max Lyons Peaked in Middle School" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/08/15/bad-plans-fonna-lll/" data-title="BAD PLANS // FONNA III" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/08/13/board-over-brains-extreme-home-video/" data-title="Board Over Brains: Extreme Home Video" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/06/26/the-hood-report-2017/" data-title="The Hood Report: 2017" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/06/05/yomerica-the-movie-2/" data-title="Yomerica: The Movie" data-featured="true"></li>

		
	
	<li data-link="http://yobeat.com/2017/06/05/best-summer-ever-yobeat-cribs/" data-title="Best Summer Ever: YoBeat Cribs" data-featured="true"></li>

	 
          
           
	</ul>
	</div>
	
        <div id="soc_book">
    	<a href="http://www.twitter.com/yobeat"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/twitter_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/twitter.png" alt="Twitter " title="Twitter " /></a>
	
        <a href="http://www.facebook.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/facebook_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/facebook.png" alt="Facebook " title="Facebook " /></a>
    
    
	    <a href="http://www.vimeo.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/vimeo_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/vimeo.png" alt="Vimeo " title="Vimeo " /></a>
    	
		
        <a href="http://www.youtube.com/yobeatdotcom"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/youtube_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/youtube.png" alt="Youtube " title="Youtube " /></a>
    	
	    
        <a href="http://www.instagram.com/yobeat"><img class="xyz tip" data-alt-src="http://yobeat.com/wp-content/themes/yobeat/images/instagram_hover.png" src="http://yobeat.com/wp-content/themes/yobeat/images/instagram.png" alt="Instagram " title="Instagram " /></a>
    
    
    </div>  
    	
</div>



	
	

<div id="header">
<div class="inner">

	<div id="title_box">
		
			
		
	    <a href="http://yobeat.com">
		    		    <img src="http://yobeat.com/wp-content/themes/yobeat/images/yobeat-logo.png" alt="Logo" id="logo"/>
	    </a>
	  
	 	
    </div>

	<div id="banner_header_970" class="mobile-hidden">
        <!-- 970x90 Leaderboard -->
        <div id='div-gpt-ad-1398272425783-0' style='width:970px; height:90px;'>
        <script type='text/javascript'>
        googletag.cmd.push(function() { googletag.display('div-gpt-ad-1398272425783-0'); });
        </script>
        </div>
	</div>		
	
	<div id="menu_box" class="closed">
		
	
    <div id="mainMenu" class="ddsmoothmenu"><ul id="menu-header" class="menu"><li id="menu-item-57927" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57927"><a href="/">Home</a></li>
<li id="menu-item-67133" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-67133"><a href="http://www.yobeatapparel.com">Yobeat Online Shop</a></li>
<li id="menu-item-57934" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-57934"><a href="http://yobeat.com/category/videos/">Videos</a>
<ul  class="sub-menu">
	<li id="menu-item-77700" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77700"><a href="http://yobeat.com/category/videos/season-edits/">Season Edits and Full Parts</a></li>
	<li id="menu-item-58418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58418"><a href="http://yobeat.com/category/videos/just-a-preview/">Just Teasers</a></li>
	<li id="menu-item-58416" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58416"><a href="http://yobeat.com/category/videos/free-movies/">Full Movies</a></li>
	<li id="menu-item-76957" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-76957"><a href="http://yobeat.com/category/thenewshow/">TheNewshow</a></li>
	<li id="menu-item-58419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58419"><a href="http://yobeat.com/category/videos/peoples-court/">People&#8217;s Court</a></li>
	<li id="menu-item-58420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58420"><a href="http://yobeat.com/category/videos/rejects-videos/">Rejected Edits</a></li>
	<li id="menu-item-66518" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66518"><a href="http://yobeat.com/category/videos/thursdays-at-the-office/">Thursdays at the Office</a></li>
</ul>
</li>
<li id="menu-item-57929" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57929"><a href="http://yobeat.com/category/cause-we-care-about-current-events/">News</a></li>
<li id="menu-item-76956" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-76956"><a href="http://yobeat.com/history-2/">History</a></li>
<li id="menu-item-57928" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-57928"><a href="http://yobeat.com/category/features/">Features</a>
<ul  class="sub-menu">
	<li id="menu-item-57958" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-57958"><a href="http://yobeat.com/category/features/people-who-are-potentially-more-interesting-than-you/">Hump Day Interviews</a></li>
	<li id="menu-item-58408" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-58408"><a href="http://yobeat.com/category/features/event-coverage/">Event Coverage</a></li>
	<li id="menu-item-66469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66469"><a href="http://yobeat.com/category/features/summer-shred-guide/">Summer Shred Guide</a></li>
	<li id="menu-item-58413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-58413"><a href="http://yobeat.com/category/features/we-know-everything/">Reviews</a>
	<ul  class="sub-menu">
		<li id="menu-item-77699" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-77699"><a href="http://yobeat.com/category/features/we-know-everything/site-check/">Site Check</a></li>
		<li id="menu-item-66470" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-66470"><a href="http://yobeat.com/category/features/toesideterrors/">Toe Side Terrors</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-78910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78910"><a href="http://yobeat.com/category/podcasts/">Podcasts</a>
<ul  class="sub-menu">
	<li id="menu-item-78911" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78911"><a href="http://yobeat.com/category/podcasts/shopcast/">Shopcast</a></li>
	<li id="menu-item-78912" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-78912"><a href="http://yobeat.com/category/podcasts/not-snowboarding-podcast/">The Not Snowboarding Podcast</a></li>
</ul>
</li>
<li id="menu-item-79419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-79419"><a href="http://yobeat.com/category/winstuff/">Win</a></li>
<li id="menu-item-57931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-57931"><a href="http://yobeat.com/about/">About</a></li>
</ul></div>    </div>
	
	
</div>	
</div>

<div class="clear"></div>

<script type="text/javascript" src="http://www.avantlink.com/affiliate_app_confirm.php?mode=js&authResponse=50ceed75f99c06037353a75765848d817f7a5b76"></script>
<div id="main_content"> 
<div class="inner cf">
	
	    
        
        
    
            

<div id="single_content">	


<div class="clear"></div>

	
    <div class="single_post" id="post-6557" class="post-6557 post type-post status-publish format-standard has-post-thumbnail hentry category-features tag-drugs tag-frat-boys tag-human-pinatas tag-legalized-drugs-in-mexico tag-mexico tag-sleeze tag-todd-richards features">
	
	   	

	   
	    		
	    <div class="single_thumbnail" style="display:none;">
		<a href="http://yobeat.com/wp-content/uploads/2009/08/tr_drugs_home.jpg" title="High Fives with Todd Richards- Mexican Drugs!" rel="prettyphoto">
	            <img src="http://yobeat.com/wp-content/uploads/2009/08/tr_drugs_home.jpg" alt="High Fives with Todd Richards- Mexican Drugs!" title="High Fives with Todd Richards- Mexican Drugs!"/>
	    </a>
		</div>
	    	   
	    			
		
	
	<div class="single_title">	  
	   <h1>High Fives with Todd Richards- Mexican Drugs!</h1> 
    </div>
	
	<div class="clear"></div>

		
	<div class="post_meta_line">
		<span class="post_time">28 August, 2009</span> 
		<span class="post_cats"><a href="http://yobeat.com/category/features/" rel="tag">Features</a></span> 
		<span class="post_views"><span class="latest-comments">10 Comments</span></span>
	</div> 
		
    <div class="clear"></div>
	
    <div class="single_text">
	    <p><img class="alignnone size-full wp-image-6559" title="tr_drugs" src="http://yobeat.com/wp-content/uploads/2009/08/tr_drugs.jpg" alt="tr_drugs" width="600" height="337" srcset="http://yobeat.com/wp-content/uploads/2009/08/tr_drugs.jpg 600w, http://yobeat.com/wp-content/uploads/2009/08/tr_drugs-300x168.jpg 300w" sizes="(max-width: 600px) 100vw, 600px" /></p>
<p><strong>Word on the street is that Mexico decided to legalize a &#8220;personal amount&#8221; of most </strong><a href="http://www.nytimes.com/2009/08/21/world/americas/21mexico.html" target="_blank"><strong>drugs</strong></a><strong>. Â Watch out spring breakers, this year should be crazy with all the legal meth around. Being as close to Mexico as possible, and old as hell, Todd knows a thing or two about Mexico, spring break, and drugs, so we had him weigh in on this ground breaking development. </strong></p>
<p><span><strong>1) Mexico just made it legal to carry a “personal” amount of most drugs. How will this change spring break?</strong></span></p>
<p><strong>Todd</strong>: Hmm, what is a personal amount? Because I know some dudes who personally need a fuck-ton. That is really interesting that Mexico did that because they recently made &#8220;being a gringo&#8221; a crime there punishable by random fine or jail time.</p>
<p><strong>2) The new law allows for .5 of a gram of cocaine, in your pocket, without arrest, but is buying blow in Mexico ever a good choice?</strong></p>
<p><strong>Todd</strong>: Oh man, if you are in Mexico trying to find the devil&#8217;s dandruff you are in a rough place. Don’t you know that you can go to your local douchebaggery and find a cocktard with jelled hair and the finest Columbian marching powder?</p>
<p><strong>3) Do you think this new Mexican law applies to Gringo tourists?</strong></p>
<p><strong>Todd</strong>: There has to be a catch to that law. Like if you are a Mexican and can afford coke it’s cool because you can also pay off the pretend police. Again, being gringo and wearing a striped shirt can land you in jail. Pretty sure the &#8220;laws&#8221; in Mexico are only suggestions.</p>
<p><strong>4) You&#8217;re allowed to carry a little herion and meth, about 40 mg’s a piece. But people that do those drugs do them all the time, do you think that part of the law was a joke?</strong></p>
<p><strong>Todd</strong>: I suggest that you don’t stuff 65 kilos of Mr. Brownstone in a Labrador Retriever and try and smuggle it into the USA. Jesus, 40 mg of meth? Is this to try and combat the cartels? Wow spring break is going to be like a whole new thing. Come on down to Squid Row for .99 cent tacos and meth! Then we have a tourist beheading at midnight,Â arriba! Human pinatas stuffed with heroin balloons.</p>
<p><strong>5) If you were going to be killed and stuffed with drugs what drug would you prefer to be stuffed with?</strong></p>
<p><strong>Todd</strong>: Shit, maybe Viagra? No, maybe Penicillin. I don’t think that I would like to be stuffed with any drug, but I do think that if I was going to die and there was no way that I would pull out of the morbid nose dive that a heroin overdose would be the most glamorous. Like if I got brain cancer, throat cancer, breast cancer, and testicular cancer coupled with herpes I would want the giant warm fuzzy way out. But for reals, Mexico legalized drugs but can’t fucking get anything else together? Jesus Cristo,Â Vicodin and horse tranqs are going to be the rage in San Diego.</p>
    </div>
	
	<div class="clear"></div>
    
    <style>
.yobeatsocial {display:block; width:100%; padding: 10px 10px 10px 0px;}
.yobeatsocial .yobeatfblike {float:left; margin-right: 30px;}
.yobeatsocial .yobeattweet {float:left;}
.yobeatsocial .yobeataddthisbutton { float:left;}
</style>
<div class="yobeatsocial">
    <div class="fb-like yobeatfblike" data-href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/" data-send="false" data-layout="button_count" data-width="90" data-show-faces="false"></div>
    <a href="https://twitter.com/share" class="twitter-share-button yobeattweet" data-url="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/" data-via="yobeat" data-related="yobeat">Tweet</a>
    <script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
    <!-- ADDTHIS BUTTON BEGIN -->
    <script type="text/javascript">
        var addthis_config = {
            services_exclude: 'facebook,twitter'
        }
    </script>
    <a href="http://www.addthis.com/bookmark.php?v=250" 
    class="addthis_counter addthis_pill_style yobeataddthisbutton"></a>
    <script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js"></script>
    <!-- ADDTHIS BUTTON END -->
    <div style="clear:both;"></div>
</div><!--yobeatsocial-->    
    <div class="clear"></div>
    
    <div id="writer" class="cf">
    <p class="cf">
        <img src='http://yobeat.com/wp-content/uploads/thumbnails/Nick Lipton.jpg' alt='' /> <strong><a href="http://yobeat.com/author/nick-lipton/" title="Posts by Nick Lipton" rel="author">Nick Lipton</a></strong> Every word in this post-even those based on real people-are entirely fictional. 
The quotes might be bullshit too.<br />
        <span><a href="/cdn-cgi/l/email-protection#d9b7aeb5b0a9adb6b799beb4b8b0b5f7bab6b4" title='Email this author'>Email this author</a> | All posts by <a href="http://yobeat.com/author/nick-lipton/" title="Posts by Nick Lipton" rel="author">Nick Lipton</a></span>
    </p>
    <div class="cf"></div>
</div>
    
    <div class="clear"></div>
	
		
		<ul id="tags_simple"><li><a href="http://yobeat.com/tag/drugs/" rel="tag">drugs</a></li><li><a href="http://yobeat.com/tag/frat-boys/" rel="tag">frat boys</a></li><li><a href="http://yobeat.com/tag/human-pinatas/" rel="tag">human pinatas</a></li><li><a href="http://yobeat.com/tag/legalized-drugs-in-mexico/" rel="tag">legalized drugs in mexico</a></li><li><a href="http://yobeat.com/tag/mexico/" rel="tag">mexico</a></li><li><a href="http://yobeat.com/tag/sleeze/" rel="tag">Sleeze</a></li><li><a href="http://yobeat.com/tag/todd-richards/" rel="tag">todd richards</a></li></ul>		
    	
	<div class="clear"></div>
	
	<div id="navigation_images">
    	<div class="alignleft">
    	        <a href="http://yobeat.com/2009/08/27/videograss-and-hard-to-earn-so-cal-premiere/">
    	<img width="150" height="150" src="http://yobeat.com/wp-content/uploads/2009/08/vg-mfm-premiere-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" 0="90" 1="90" />    	</a>
            	
    	<div class="prev_link_title">
    	<span>- Previous article</span> </br>
        &laquo; <a href="http://yobeat.com/2009/08/27/videograss-and-hard-to-earn-so-cal-premiere/" rel="prev">Videograss and Hard to Earn So Cal Premiere</a>        </div>
    	
    	</div> 
    	
    	<div class="alignright">
    	
    	        <a href="http://yobeat.com/2009/08/28/whats-up-with-matty-ryan/">
    	<img width="150" height="150" src="http://yobeat.com/wp-content/uploads/2009/08/whatsup_mattyryan_home-150x150.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" 0="90" 1="90" />    	</a>
            	
    	<div class="next_link_title">
    	<span>Next article -</span></br>
    	<a href="http://yobeat.com/2009/08/28/whats-up-with-matty-ryan/" rel="next">What&#8217;s Up with Matty Ryan</a> &raquo;        </div>
    	</div>

	</div> 
	
	<div class="clear"></div>
	
    	<div id="similar-post" class="mosaicflow" data-item-selector=".similar_posts" data-min-item-width="200"> 
 
	    <h3> Similar posts </h3><div class="clear"></div><ul>		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2017/05/03/nate-bozungs-last-hump-day/" title="Nate Bozung&#8217;s Last Hump Day" >
			            <img src="http://yobeat.com/wp-content/uploads/2010/07/boznuts_art-360x220.jpg" alt="Nate Bozung&#8217;s Last Hump Day" title="Nate Bozung&#8217;s Last Hump Day"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2017/05/03/nate-bozungs-last-hump-day/" title="Nate Bozung&#8217;s Last Hump Day" >Nate Bozung&#8217;s Last Hump Day</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/features/" rel="tag">Features</a>, <a href="http://yobeat.com/category/features/people-who-are-potentially-more-interesting-than-you/" rel="tag">Hump Day Interviews</a></span>
			
	    </li>
		
        		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2017/02/20/outer-rim/" title="Outer Rim" >
			            <img src="http://yobeat.com/wp-content/uploads/2017/02/Screen-Shot-2017-02-20-at-1.50.15-PM-360x220.png" alt="Outer Rim" title="Outer Rim"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2017/02/20/outer-rim/" title="Outer Rim" >Outer Rim</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/features/" rel="tag">Features</a>, <a href="http://yobeat.com/category/videos/" rel="tag">Videos</a></span>
			
	    </li>
		
        		
		<li class="similar_posts">
		
		    	 
            	
            <a href="http://yobeat.com/2016/06/16/todd-richards-joins-the-circus/" title="Todd Richards Joins the Circus" >
			            <img src="http://yobeat.com/wp-content/uploads/2016/06/Screen-Shot-2016-06-16-at-10.35.04-AM-360x220.png" alt="Todd Richards Joins the Circus" title="Todd Richards Joins the Circus"/>					
            </a>
            	
		
			<h1><a href="http://yobeat.com/2016/06/16/todd-richards-joins-the-circus/" title="Todd Richards Joins the Circus" >Todd Richards Joins the Circus</a></h1>

			<span class="post_cats"><a href="http://yobeat.com/category/cause-we-care-about-current-events/" rel="tag">News</a></span>
			
	    </li>
		
        </ul>        		
    </div>	 
		 
	
	<div class="clear"></div>

		
		
	<div id="comments">

<!-- You can start editing here. -->

	<div class="comment-header"><h3>Comments (10)</h3></div>
	<div id="commentlist-wrap">
		<ol class="commentlist">
                    <li class="comment even thread-even depth-1" id="comment-6434">
                <div id="div-comment-6434" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://2.gravatar.com/avatar/b3d998457273a0d32e7eb8f12042a6d5?s=50&#038;r=g' srcset='http://2.gravatar.com/avatar/b3d998457273a0d32e7eb8f12042a6d5?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6434">
                    <cite class="fn">Zimmerman</cite> <span class="says">said:</span>                    said on August 28, 2009 at 10:13 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>For the record: Mexico can get bent sideways and die.</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64351"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6434#respond' onclick='return addComment.moveForm( "div-comment-6434", "6434", "respond", "6557" )' aria-label='Reply to Zimmerman'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment odd alt thread-odd thread-alt depth-1" id="comment-6435">
                <div id="div-comment-6435" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://0.gravatar.com/avatar/cdb8a94693c6334794b9faa63e26603c?s=50&#038;r=g' srcset='http://0.gravatar.com/avatar/cdb8a94693c6334794b9faa63e26603c?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6435">
                    <cite class="fn">Satan's Horticulturist</cite> <span class="says">said:</span>                    said on August 28, 2009 at 10:18 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>Certainly one way to thin the heard</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64361"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6435#respond' onclick='return addComment.moveForm( "div-comment-6435", "6435", "respond", "6557" )' aria-label='Reply to Satan&#039;s Horticulturist'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment even thread-even depth-1" id="comment-6436">
                <div id="div-comment-6436" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://0.gravatar.com/avatar/908b0b415bd7f895c32415d219a7abb2?s=50&#038;r=g' srcset='http://0.gravatar.com/avatar/908b0b415bd7f895c32415d219a7abb2?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6436">
                    <cite class="fn"><a href='http://www.Quiksilver.com/todcast' rel='external nofollow' class='url'>Trichards</a></cite> <span class="says">said:</span>                    said on August 28, 2009 at 10:30 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>Zim did you get a Mexican colonoscopy courtesy of the Mexican pretend police ?</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64371"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6436#respond' onclick='return addComment.moveForm( "div-comment-6436", "6436", "respond", "6557" )' aria-label='Reply to Trichards'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment odd alt thread-odd thread-alt depth-1" id="comment-6466">
                <div id="div-comment-6466" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://2.gravatar.com/avatar/b3d998457273a0d32e7eb8f12042a6d5?s=50&#038;r=g' srcset='http://2.gravatar.com/avatar/b3d998457273a0d32e7eb8f12042a6d5?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6466">
                    <cite class="fn">Zimmerman</cite> <span class="says">said:</span>                    said on August 28, 2009 at 12:00 pm</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>No Todd, nothing that invasive. Just got robbed by the pretend police, so did 3 other car loads of shred dudes on the same day, in different spots, at different times of day.</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64671"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6466#respond' onclick='return addComment.moveForm( "div-comment-6466", "6466", "respond", "6557" )' aria-label='Reply to Zimmerman'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment even thread-even depth-1" id="comment-6478">
                <div id="div-comment-6478" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://2.gravatar.com/avatar/81b9d15d1d4ceb7c8fcf8af88affc3fd?s=50&#038;r=g' srcset='http://2.gravatar.com/avatar/81b9d15d1d4ceb7c8fcf8af88affc3fd?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6478">
                    <cite class="fn"><a href='http://www.shredthegnarbrah.blogspot.com' rel='external nofollow' class='url'>mel</a></cite> <span class="says">said:</span>                    said on August 28, 2009 at 5:21 pm</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>i have never been to the horrible parts of Mexico&#8230;and personally this article really seals the deal on never planning that trip. i mean i&#8217;m white and i have tits and a vag &#8211; im pretty much just asking for it&#8230;</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64791"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6478#respond' onclick='return addComment.moveForm( "div-comment-6478", "6478", "respond", "6557" )' aria-label='Reply to mel'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment odd alt thread-odd thread-alt depth-1" id="comment-6480">
                <div id="div-comment-6480" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://0.gravatar.com/avatar/908b0b415bd7f895c32415d219a7abb2?s=50&#038;r=g' srcset='http://0.gravatar.com/avatar/908b0b415bd7f895c32415d219a7abb2?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6480">
                    <cite class="fn"><a href='http://www.Quiksilver.com/todcast' rel='external nofollow' class='url'>Trichards</a></cite> <span class="says">said:</span>                    said on August 28, 2009 at 5:52 pm</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>Why would you plan a trip to the worst part of Mexico? That&#8217;s like palnning a vacation to Cleaveland.<br />
   <a href="http://www.youtube.com/watch?v=oZzgAjjuqZM" rel="nofollow">http://www.youtube.com/watch?v=oZzgAjjuqZM</a></p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-64811"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6480#respond' onclick='return addComment.moveForm( "div-comment-6480", "6480", "respond", "6557" )' aria-label='Reply to Trichards'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment even thread-even depth-1" id="comment-6519">
                <div id="div-comment-6519" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://2.gravatar.com/avatar/28e0eccaf93778e285ebefdf9541cde2?s=50&#038;r=g' srcset='http://2.gravatar.com/avatar/28e0eccaf93778e285ebefdf9541cde2?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6519">
                    <cite class="fn">Good one Mel, moron</cite> <span class="says">said:</span>                    said on August 29, 2009 at 11:45 pm</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>I have never been to the gay parts of San Francisco&#8230;I mean really, these articles on AIDS seals the deal for me.  I mean I&#8217;m black, have a huge swinging dick and a tight ass &#8211; I&#8217;m pretty much asking for it&#8230;</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-65201"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6519#respond' onclick='return addComment.moveForm( "div-comment-6519", "6519", "respond", "6557" )' aria-label='Reply to Good one Mel, moron'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment odd alt thread-odd thread-alt depth-1" id="comment-6528">
                <div id="div-comment-6528" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://2.gravatar.com/avatar/bfde251aec6bc9aac0752377247d16e8?s=50&#038;r=g' srcset='http://2.gravatar.com/avatar/bfde251aec6bc9aac0752377247d16e8?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6528">
                    <cite class="fn"><a href='http://www.youporn.com' rel='external nofollow' class='url'>steve</a></cite> <span class="says">said:</span>                    said on August 30, 2009 at 10:51 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>yeah mel you moron</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-65291"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6528#respond' onclick='return addComment.moveForm( "div-comment-6528", "6528", "respond", "6557" )' aria-label='Reply to steve'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="comment even thread-even depth-1" id="comment-6546">
                <div id="div-comment-6546" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                    <img alt='' src='http://1.gravatar.com/avatar/d761a42478c32e6843ac34069814a32b?s=50&#038;r=g' srcset='http://1.gravatar.com/avatar/d761a42478c32e6843ac34069814a32b?s=100&amp;r=g 2x' class='avatar avatar-50 photo' height='50' width='50' />                </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-6546">
                    <cite class="fn">Summit County</cite> <span class="says">said:</span>                    said on August 31, 2009 at 10:03 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>mexico is good for only one thing and that&#8217;s donkey shows!!!</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-65471"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=6546#respond' onclick='return addComment.moveForm( "div-comment-6546", "6546", "respond", "6557" )' aria-label='Reply to Summit County'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
        <li class="pingback odd alt thread-odd thread-alt depth-1" id="comment-1108740">
                <div id="div-comment-1108740" class="comment-body cf">
                
            <div class="comment-left">
                <div class="comment-author vcard">
                                    </div>
            </div>
            <div class="comment-right">
                
                <div class="comment-meta commentmetadata"><a href="http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/#comment-1108740">
                    <cite class="fn"><a href='http://yobeat.com/2014/02/28/six-tips-for-smoking-weed-at-a-resort/' rel='external nofollow' class='url'>Six Tips for Smoking Weed at a Resort</a></cite> <span class="says">said:</span>                    said on September 5, 2017 at 6:19 am</a>                </div>

                
                
                <div class="comment-text cf">
                    <p>[&#8230;] in terrain parks and tree lines across America. And seeing how YoBeat has a history of covering the use of substances, and with the recent Inside Edition and Leo’s fiasco, why not dedicate another [&#8230;]</p>
<table class="rw-rating-table rw-ltr rw-left rw-no-labels">
<tr>
<td><nobr>&nbsp;</nobr></td>
<td>
<div class="rw-left">
<div class="rw-ui-container rw-class-comment rw-urid-11087411"></div>
</div>
</td>
</tr>
</table>
                </div>
                
                <div class="cf"></div>
                
                                
                <div class="reply">
                    <a rel='nofollow' class='comment-reply-link' href='http://yobeat.com/2009/08/28/high-fives-with-todd-richards-15/?replytocom=1108740#respond' onclick='return addComment.moveForm( "div-comment-1108740", "1108740", "respond", "6557" )' aria-label='Reply to Six Tips for Smoking Weed at a Resort'>Reply</a>                </div>
                
                <div class="cf"></div>
                
            </div>

                </div>
        </li><!-- #comment-## -->
		</ol>
		<div class="comment-nav">
                    </div> <!-- end comment pagination -->
        <div class="clear"></div>
	</div>

	
	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2009/08/28/high-fives-with-todd-richards-15/#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="http://yobeat.com/wp-comments-post.php?wpe-comment-post=yobeat" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label> <textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='6557' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="ab96276702" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="143"/></p>			</form>
			</div><!-- #respond -->
	
</div>

<div class="clear"></div>	
		
	
			 

</div>

</div>
	
<div class="right-sidebar">
    
<div id="sidebar-right">

<div class="right-sidebar-widget widget_search">
<form class="search" method="get" action="http://yobeat.com/">
	<input type="text" name="s" id="s" placeholder="Search..." />
</form></div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><div class="sidebar-ad"><!-- /1804608/300x600_UpperSidebar -->
<div id='div-gpt-ad-1440105287696-0' style='height:600px; width:300px;'>
<script>!function(e,t,r,n,c,h,o){function a(e,t,r,n){for(r='',n='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^n);return r}try{for(c=e.getElementsByTagName('a'),o='/cdn-cgi/l/email-protection#',n=0;n<c.length;n++)try{(t=(h=c[n]).href.indexOf(o))>-1&&(h.href='mailto:'+a(h.href,t+o.length))}catch(e){}for(c=e.querySelectorAll('.__cf_email__'),n=0;n<c.length;n++)try{(h=c[n]).parentNode.replaceChild(e.createTextNode(a(h.getAttribute('data-cfemail'),0)),h)}catch(e){}}catch(e){}}(document);</script><script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1440105287696-0'); });
</script>
</div></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><div class="sidebar-ad"><!-- /1804608/300x600_LowerSidebar -->
<div id='div-gpt-ad-1430774177852-0' style='height:600px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430774177852-0'); });
</script>
</div>
</div></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><div class="sidebar-ad"><!-- /1804608/MiddleSidebar_300x250 -->
<div id='div-gpt-ad-1432930178175-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1432930178175-0'); });
</script>
</div></div>
		</div><div class="right-sidebar-widget popular-widget"><div class="right-heading"><h3>Popular Posts</h3></div> <div class="clear"></div>
		<ul class="widget_recent_posts">
						<li>
								<a href="http://yobeat.com/2017/08/13/board-over-brains-extreme-home-video/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-13-at-9.15.54-PM-90x65.png" alt="Board Over Brains: Extreme Home Video" title="Board Over Brains: Extreme Home Video" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/08/13/board-over-brains-extreme-home-video/" rel="bookmark">Board Over Brains: Extreme Home Video</a>
				<div class="widget_date">13 August, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/08/11/pretty-in-pink-danyale-patteraon-1516/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-11-at-10.25.46-AM-90x65.png" alt="Pretty in Pink: Danyale Patterson 15/16" title="Pretty in Pink: Danyale Patterson 15/16" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/08/11/pretty-in-pink-danyale-patteraon-1516/" rel="bookmark">Pretty in Pink: Danyale Patterson 15/16</a>
				<div class="widget_date">11 August, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/08/11/luke-haddock-at-sugarbush-2/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-11-at-10.51.09-AM-90x65.png" alt="Luke Haddock at Sugarbush" title="Luke Haddock at Sugarbush" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/08/11/luke-haddock-at-sugarbush-2/" rel="bookmark">Luke Haddock at Sugarbush</a>
				<div class="widget_date">11 August, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/08/16/max-lyons-peaked-in-middle-school/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-16-at-5.11.07-PM-90x65.png" alt="Max Lyons Peaked in Middle School" title="Max Lyons Peaked in Middle School" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/08/16/max-lyons-peaked-in-middle-school/" rel="bookmark">Max Lyons Peaked in Middle School</a>
				<div class="widget_date">16 August, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
							<li>
								<a href="http://yobeat.com/2017/08/31/whole-lotta-gang-shit/">
					
				<span class="widget_thumbnail">
				                <img src="http://yobeat.com/wp-content/uploads/2017/08/Screen-Shot-2017-08-31-at-7.51.50-PM-90x65.png" alt="WHOLE LOTTA GANG SHIT!" title="WHOLE LOTTA GANG SHIT!" />
				 </span>
				</a>
								<div class="widget_info">
				<a class="widget_title" href="http://yobeat.com/2017/08/31/whole-lotta-gang-shit/" rel="bookmark">WHOLE LOTTA GANG SHIT!</a>
				<div class="widget_date">31 August, 2017</div>
			    </div>
			<div class="clear"></div>	
			</li>
						</ul>
			</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><div class="sidebar-ad"><!-- /1804608/300x250_Jared -->
<div id='div-gpt-ad-1434661344746-0' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1434661344746-0'); });
</script>
</div>
</div></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><div class="sidebar-ad"><!-- /1804608/300x600-Jared-Lower -->
<div id='div-gpt-ad-1463688777883-0' style='height:600px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1463688777883-0'); });
</script>
</div>
</div></div>
		</div><div class="right-sidebar-widget widget_text">			<div class="textwidget"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- yobeat ad -->
<ins class="adsbygoogle"
     style="display:inline-block;width:336px;height:280px"
     data-ad-client="ca-pub-8291993506529710"
     data-ad-slot="7073164773"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
		</div> 	

</div>
  
</div>
	
</div>
</div>

<div class="clear"></div>
	
<div class="clear"></div>

<br />

<div id="footer_bottom"> 

    <div id="secondaryMenu" class="menu-footer-container"><ul id="menu-footer" class="menu"><li id="menu-item-65403" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65403"><a href="http://yobeat.com/about/">About</a></li>
<li id="menu-item-65404" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-65404"><a href="http://yobeat.com/selfserveadvertising/">Advertise</a></li>
<li id="menu-item-65405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-65405"><a target="_blank" href="http://www.yobeatapparel.com/">Buy Yobeat Merch</a></li>
</ul></div>

    <div id="credit">     
	 &copy; 2017 	  All rights reserved -
	  <a href="http://yobeat.com" title="YoBeat: Softcore Snowboarding Since 1997">YoBeat: Softcore Snowboarding Since 1997</a>.
	  &nbsp;  Built By <a href="http://clave.me/" target="blank">Clave Media</a>
    </div>	


</div>

<script type="text/javascript">
jQuery(document).ready(function($){
	$(".tagcloud a").hover(function() {
    $(this).animate({ backgroundColor: "#f14d4d" }, 200);
    },function() {
    $(this).animate({ backgroundColor: "#444" }, 200);
    });
});
</script>

</div>
<a href="#top" class="scroll-top-link mobile-hidden">TOP</a>
<!-- ngg_resource_manager_marker --><script type='text/javascript'>
/* <![CDATA[ */
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/yobeat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
var thickboxL10n = {"next":"Next >","prev":"< Prev","image":"Image","of":"of","close":"Close","noiframes":"This feature requires inline frames. You have iframes disabled or your browser does not support them.","loadingAnimation":"http:\/\/yobeat.com\/wp-includes\/js\/thickbox\/loadingAnimation.gif"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/thickbox/thickbox.js?ver=3.1-20121105'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"http:\/\/yobeat.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"http:\/\/yobeat.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/sagenda/js/sagenda-datepicker.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/sagenda/js/sagenda.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.totemticker.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/carousel.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/creamsoda_ticker.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/carousel_plugins.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.flexslider-min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/ddsmoothmenu.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.easing.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.mosaicflow.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.color.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.prettyPhoto.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/jquery.tipTip.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/modernizr.custom.46884.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/css_browser_selector.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/themes/yobeat/js/yobeat.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/comment-reply.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jail.js?ver=3.2.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jquery-mousewheel/jquery.mousewheel.min.js?ver=3.0.6'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/jquery.easing.1.3.js?ver=1.3'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/slidedeck.jquery.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/slidedeck3-personal/js/slidedeck-public.js?ver=3.2.3'></script>
<script type='text/javascript' src='http://platform.twitter.com/widgets.js?ver=1316526300'></script>
<script type='text/javascript' src='http://yobeat.com/wp-includes/js/wp-embed.min.js?ver=4.8.1'></script>
<script type='text/javascript' src='http://yobeat.com/wp-content/plugins/akismet/_inc/form.js?ver=3.3.3'></script>
					<!-- This site's ratings are powered by RatingWidget plugin v2.5.9 - https://rating-widget.com/wordpress-plugin/ -->
					<div class="rw-js-container">
						<script type="text/javascript">

							// Initialize ratings.
							function RW_Async_Init(){
								RW.init({uid: "7e6a4b898e25d24ad34b1ae06609159e", huid: "242136",
									source: "wordpress",
									options: {
																	},
								identifyBy: "laccount"
							});
														var options = {"type":"nero","theme":"thumbs_1"};
														RW.initClass("comment", options);
							RW.initRating("64351", {title: "For the record: Mexico can get bent sideways and die.", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6434"});RW.initRating("64361", {title: "Certainly one way to thin the heard", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6435"});RW.initRating("64371", {title: "Zim did you get a Mexican colonoscopy courtesy of the Mexican pretend police ?", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6436"});RW.initRating("64671", {title: "No Todd, nothing that invasive. Just got robbed by the pretend police, so did 3 other car loads of shred dudes on the same day, in different spots, at different times of day.", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6466"});RW.initRating("64791", {title: "i have never been to the horrible parts of Mexico...and personally this article really seals the deal on never planning that trip. i mean i\\'m white and i have tits and a vag - im pretty much just asking for it...", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6478"});RW.initRating("64811", {title: "Why would you plan a trip to the worst part of Mexico? That\\'s like palnning a vacation to Cleaveland.\\n   http:\/\/www.youtube.com\/watch?v=oZzgAjjuqZM", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6480"});RW.initRating("65201", {title: "I have never been to the gay parts of San Francisco...I mean really, these articles on AIDS seals the deal for me.  I mean I\\'m black, have a huge swinging dick and a tight ass - I\\'m pretty much asking for it...", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6519"});RW.initRating("65291", {title: "yeah mel you moron", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6528"});RW.initRating("65471", {title: "mexico is good for only one thing and that\\'s donkey shows!!!", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-6546"});RW.initRating("11087411", {title: "[&#8230;] in terrain parks and tree lines across America. And seeing how YoBeat has a history of covering the use of substances, and with the recent Inside Edition and Leo\u2019s fiasco, why not dedicate another [&#8230;]", url: "http:\/\/yobeat.com\/2009\/08\/28\/high-fives-with-todd-richards-15\/#comment-1108740"});							RW.render(function() {
								(function($) {
									$('.rw-rating-table:not(.rw-no-labels)').each(function() {
										var ratingTable = $(this);

										// Find the current width before floating left or right to
										// keep the ratings aligned
										var col1 = ratingTable.find('td:first');
										var widthCol1 = col1.width();
										ratingTable.find('td:first-child').width(widthCol1);

										if (ratingTable.hasClass('rw-rtl')) {
											ratingTable.find('td').css({float: 'right'});
										} else {
											ratingTable.find('td').css({float: 'left'});
										}
									});
								})(jQuery);
							}, true);
							}

							RW_Advanced_Options = {
								blockFlash: !(1)
							};

							// Append RW JS lib.
							if (typeof(RW) == "undefined"){
								(function(){
									var rw = document.createElement("script");
									rw.type = "text/javascript"; rw.async = true;
									rw.src = "http://js.rating-widget.com/external.min.js?ck=Y2017M09D05?wp=2.5.9";
									var s = document.getElementsByTagName("script")[0]; s.parentNode.insertBefore(rw, s);
								})();
							}
						</script>
					</div>
					<!-- / RatingWidget plugin -->
					  <!-- VigLink: http://viglink.com -->
  <script type="text/javascript">
    var vglnk = { key: '443f52e4645464c28eb7fc11321ff834' };

    (function(d, t) {
      var s = d.createElement(t); s.type = 'text/javascript'; s.async = true;
      s.src = '//cdn.viglink.com/api/vglnk.js?key=' + vglnk.key;
      var r = d.getElementsByTagName(t)[0]; r.parentNode.insertBefore(s, r);
    }(document, 'script'));
  </script>
  <!-- end VigLink -->
<script type="text/javascript">
var slideDeck2URLPath = "http://yobeat.com/wp-content/plugins/slidedeck3-personal";
var slideDeck2iframeByDefault = false;
</script>
<!-- AdRotate JS -->
<script type="text/javascript">
</script>
<!-- /AdRotate JS -->



<!-- Start Quantcast tag -->
<script type="text/javascript">_qoptions={qacct:"p-505kElD5BGXpI"};</script>
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<noscript><img src="http://pixel.quantserve.com/pixel/p-505kElD5BGXpI.gif" style="display: none;" border="0" height="1" width="1" alt="Quantcast"/></noscript>
<!-- End Quantcast tag -->

<script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script>


</body>

</html>
	
	